Using MINISASTOCSI camera module with i.MX 8QuadMax MEK CPU Board (imx8qmmek)

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Using MINISASTOCSI camera module with i.MX 8QuadMax MEK CPU Board (imx8qmmek)

Jump to solution
705 Views
amberworth
Contributor III

I'm trying to get the MINISASTOCSI camera module to work with the i.MX 8QuadMax MEK CPU board.

I've connected the SAS plug from J10 (CSI0?) to the MIPICSI camera.

I'm loading it with an imx-image-full yocto build.

After linux boot, the camera is not showing up. (no video sources show  when I run  gst-device-monitor-1.0)

Things I've tried:

  1. Making sure that the SAS connector is well seated on both sides (audible clicks)
  2. Connecting to J5 (CSI1?).  This made no difference.
  3. Stopping at uboot and trying "setenv fdt_file fsl-imx-evk-mipi-csi2.dtb". This ended up breaking the device tree. When I tried to start linux with run bootcmd, I got "WARN: Cannot load the DT" followed by an <INTERRUPT> and linux failed to load.

 

Question:

Where am I supposed to attach the camera (is CSI0 correct)?

What do I need to add to the build in order access the camera?

 

0 Kudos
1 Solution
691 Views
amberworth
Contributor III

I figured out what the problem was, I was trying to use the wrong device tree file.  I changed it to 

setenv fdt_file imx8qm-mek-ov5640.dtb

The system then was able to load the camera.

 

This can be closed.

View solution in original post

0 Kudos
1 Reply
692 Views
amberworth
Contributor III

I figured out what the problem was, I was trying to use the wrong device tree file.  I changed it to 

setenv fdt_file imx8qm-mek-ov5640.dtb

The system then was able to load the camera.

 

This can be closed.

0 Kudos