Reboot imx6qp

cancel
Showing results for 
Search instead for 
Did you mean: 

Reboot imx6qp

580 Views
corentinmorisse
Contributor I

Hi Community,

  

We have a custom board designed for a imx6DL using a design imx6qsabresd, booting from a eMMC v4.41, which is working fine.

 

We replaced the processor with a imx6 Quad Plus and use a eMMC v5.0 (MTFC16GAKAECN-4M)

We use Linux 4.1.15 and u-boot 2016.03-r0.

But now, the reboot hang.

The last message send by the board is « Rebooting... reboot: Restarting system ».

The board seem to reuse the DCD code loaded in the first boot (if we change the DCD code written in the eMMC after starting the board, when rebooting it will use the old one).

It hang immediately after, and the board go to serial downloader mode.

Using Boot_Tester.exe, it show that the imx seem to fail to access to the eMMC :

*********************************************

Boot Debug (106.1) for MX6DQ or MX6DQplus

Build: Nov 10 2015, 21:43:53

Freescale Semiconductor, Inc.

*********************************************

WDOG Fuse Disabled

Boot_cfg_1 = 0x70

Boot_cfg_2 = 0xd0

Boot_cfg_3 = 0x00

Boot_cfg_4 = 0x4b

SBMR2        = 0x0a000001

BMOD        = 10 Boot from GPIO/Fuses

BT_FUSE_SEL = 0

DIR_BT_DIS  = 0

SEC_CONFIG  = 01

Persistent Reg Value: 0x40000000

iROM Version = 0x20

USB_ANALOG_DIGPROG = 0x00630100

Device            = MX6 Dual/Quad Plus

Si Revision       = 2.0

Log Entry #0  (0x00010002) BOOTMODE - Internal/Override

Log Entry #1  (0x000200f0) Security Mode - Open

Log Entry #2  (0x00030000) DIR_BT_DIS = 0

Log Entry #3  (0x00040000) BT_FUSE_SEL = 0

Log Entry #4  (0x00050001) Secondary Image Selected

Log Entry #5  (0x00060001) USDHC Boot

Log Entry #6  (0x00070000) Device INIT Call

Log Entry #7  (0x000700f0) Device INIT Pass

Log Entry #8  (0x00080000) Device READ Data Call Address: 0x00000000

Log Entry #10 (0x000800f0) Device READ Data Pass

Log Entry #11 (0x00061004) Recovery Mode ECSPI

Log Entry #12 (0x00080000) Device READ Data Call Address: 0x00000000

Log Entry #14 (0x000800f0) Device READ Data Pass

Log Entry #15 (0x00090000) HAB Authentication Status Code:

              (0x000a0533) Invalid IVT

Log Entry #17 (0x000c0000) Serial Downloader Entry

Log Entry #18 (0x00090000) HAB Authentication Status Code:

              (0x000a0533) Invalid IVT

Log Entry #20 (0x000d0000) Serial Downloader Call

              (0x0091712c) Address: 0x0091712c

       

We don’t use HAB, the board is in open mode.

Labels (1)
Tags (2)
0 Kudos
6 Replies

203 Views
b45499
NXP TechSupport
NXP TechSupport

Hi,

When you change to the eMMC v5.0 you need to do some modify in souce code. You can refer to the thread

EMMC 5.0 and EMMC 5.1 work on i.MX6
Have a great day,
Rita

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

203 Views
julienc
Contributor II

Hi Rita, 

Thanks for your answer. I work with Corentin on the project  but we use Linux 4.1.15 BSP release and the patch for support eMMC V5.0 and V5.1 is already applied.

We succeed to boot from eMMC but as i read in the thread " boot ROM will fall back to the eMMC4.4 standard when a eMMC4.5 or high version capable device is detected" , the reboot is not possible ?

As i am correct ? Any fix for detection possible ?

Thanks 

Julien

0 Kudos

203 Views
b45499
NXP TechSupport
NXP TechSupport

Hi Julien,

In our newest BSP, the driver support the emmc5.0 protocol and the performance is better than emmc4.41.The boot up is OK, the word you mentioned above mean that "The EMMC 4.5 or EMMC 5.0 /5.1 is backward-compatible with eMMC4.4". The emmc V5.0 and V5.1 can work on i.MX6. No problem.

Have a nice day

Rita

203 Views
julienc
Contributor II

I understand than i can boot from eMMC with ixm6 and eMMC V5.0 as eMMC V4.4 protocol but if we try to reboot with linux system the system still hang on the DCD code and not reload u-boot but with eMMC 4.4 the system reboot normally.

So i don't understand why it's only happening with eMMC V5.0.

Thanks for help.

Julien

0 Kudos

203 Views
b45499
NXP TechSupport
NXP TechSupport

You need to check your hardware or software setting.

0 Kudos

203 Views
corentinmorisse
Contributor I

For the hardware, the board work fine with a imx6DL and a eMMC v4.41, we replaced the processor with a imx6 Quad Plus and use a eMMC v5.0, so it seem that it’s not a hardware setting problem.

For the software, we use your driver, and the eMMC is configured to boot in x8ddr mode.

Thanks

Corentin

0 Kudos