Re: LVDS resolution problem

cancel
Showing results for 
Search instead for 
Did you mean: 

Re: LVDS resolution problem

549 Views
art
NXP TechSupport
NXP TechSupport

Try to add 'allow_noncea=1' environment variable to the u-boot configuration:

U-Boot>setenv allow_noncea 1


Have a great day,
Artur

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
1 Reply

58 Views
kikimorisato
Contributor II

allow_noncea=1


is there are for HDMI ??


i want to set LVDS


-----------------------------------------


setenv allow_noncea 1 ==> still LVDS resolution is 1024x768


so i create patch file

but still LVDS resolution is 1024x768


diff -uprN a/arch/arm/boot/dts/imx6qdl-sabresd.dtsi b/arch/arm/boot/dts/imx6qdl-sabresd.dtsi

--- a/arch/arm/boot/dts/imx6qdl-sabresd.dtsi 2015-04-22 14:05:06.303517000 +0900

+++ b/arch/arm/boot/dts/imx6qdl-sabresd.dtsi 2015-04-22 16:18:11.283748594 +0900

@@ -822,14 +822,14 @@

  display-timings {

  native-mode = <&timing0>;

- timing0: hsd100pxn1 {

- clock-frequency = <65000000>;

+ timing0: zj080na {

+ clock-frequency = <51200000>;

  hactive = <1024>;

- vactive = <768>;

- hback-porch = <220>;

- hfront-porch = <40>;

- vback-porch = <21>;

- vfront-porch = <7>;

+ vactive = <600>;

+ hback-porch = <160>;

+ hfront-porch = <160>;

+ vback-porch = <23>;

+ vfront-porch = <12>;

  hsync-len = <60>;

  vsync-len = <10>;

  };

---------------------------------------------------------------------------------------------------------------------------------------------

before question

BSP: fsl-community-bsp (fido branch)

Kernel Version: 3.14.28

Board: SabreSD (mx6q)

LCD: Innolux 1024x600 LVDS

no X11 (frame buffer use)

Kernel command line: console=ttymxc0,115200 root=/dev/mmcblk2p2 rootwait rw video=mxcfb0:dev=ldb,1024x600M@60

u-boot lcd resolution is OK

but linux lcd resolution is always 1024x768

for examples

1. gstreamer

gst-launch v4l2src device=/dev/video0  ! 'video/x-raw-yuv, format=(fourcc)UYVY' ! mfw_isink

than ==>

MAX resolution 1024x768

MFW_GST_ISINK_PLUGIN 4.0.3 build on Apr 20 2015 18:43:18.

Setting pipeline to PAUSED ...tw6869 0000:01:00.0: vch0 std NTSC (M)

tw6869 0000:01:00.0: vch0 fps 29

tw6869 0000:01:00.0: DMA 0 ON

Pipeline is live and does not need PREROLL ...

Setting pipeline to PLAYING ...

New clock: GstSystemClock

hwbuf allocator zone(692224) created

VS0 created. in fmt[YUYV] win(0,0-720,480:720x480) out win(0,0-1024,768:1024x768)

set deinterlace mode 0

2. QT5.4.1 resizeGL (from system width height)

W = 1024

H = 768

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

how can i change linux LVDS resolution

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


and max11801 touch device resolution is 1024x768 too

0 Kudos