QtTestBrowser (eglfs) bad performance with webgl - iMX6Q

Showing results for 
Search instead for 
Did you mean: 

QtTestBrowser (eglfs) bad performance with webgl - iMX6Q

Contributor IV


I downloaded Qt5.4-beta and compiled in order to test the QtTestBrowser application with WebGL because it was performing awfully in Qt5.3.

I notice that with Qt5.4-beta it is getting slightly better with regards to CPU load but still it is a questionable performance !

I run some online webgl test like:

./QtTestBrowser -platform eglfs -graphicsbased -opengl-viewport -webgl -plugin evdevmouse:/dev/event1 http://ahoj.io/dart-webgl-simple-demo

and the CPU load is around 55% and I can see that the galcore daemon is around 1%.

Is there anybody that has some input on this ? Are those maybe expected results ? if so, what browser could perform better ?



Labels (3)
Tags (4)
2 Replies

NXP TechSupport
NXP TechSupport

Hi Einar

I think you can look below and probably ask

Freescale OpenEmbedded/Yocto Layers discussion list ()

Best regards


Contributor IV

Hi Igor and thanks for the reply.

I looked through the thread and surely they are addressing those things that matter to me, i.e. accelerated browsing/compositing/canvas in Chromium.

I am pretty excited about Chromium but I think qtwebengine can't be compiled for embedded Linux as is, according to this thread: Qt 5.4 Beta Available | Qt Blog. (Not correct) At least my efforts have failed.

I have been looking into the QtTestBrowser and did a bit of profiling of it and I can't see that switching on/off the 2D acceleration makes any difference on Canvas or SVG tests. So my conclusion is that it is not being accelerated or worse, doing a terrible job on it.

And btw, Canvas performance is somehow down the toilet.

I ran these tests against my laptop:

- SVG test: http://bl.ocks.org/stepheneb/1296930

-- 2x better performance on my laptop than on my i.MX6Q based board

- Canvas test: http://bl.ocks.org/stepheneb/1297383

-- 10x better performance on my laptop than on my i.MX6Q based board

I also ran MiniBrowser which is WebKit2 based browser and it crashes with this bt:

#0  0x727b7276 in ?? () from /lib/arm-linux-gnueabihf/libc.so.6

#1  0x727c4e82 in raise () from /lib/arm-linux-gnueabihf/libc.so.6

#2  0x727c725c in abort () from /lib/arm-linux-gnueabihf/libc.so.6

#3  0x744af3cc in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/qt5/libQt5Core.so.5

#4  0x74b2ea1c in QV4::ExecutionEngine::ExecutionEngine(QV4::EvalISelFactory*) () from /usr/lib/qt5/libQt5Qml.so.5

#5  0x74c526a4 in QV8Engine::QV8Engine(QJSEngine*) () from /usr/lib/qt5/libQt5Qml.so.5

#6  0x74b0113c in QJSEngine::QJSEngine(QJSEnginePrivate&, QObject*) () from /usr/lib/qt5/libQt5Qml.so.5

#7  0x74bc66bc in QQmlEngine::QQmlEngine(QObject*) () from /usr/lib/qt5/libQt5Qml.so.5

#8  0x76e0b808 in ?? () from /usr/lib/qt5/libQt5Quick.so.5

Cannot access memory at address 0x0

#9  0x76e0b808 in ?? () from /usr/lib/qt5/libQt5Quick.so.5

Cannot access memory at address 0x0

Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Anyone has an idea about that !!!