QT5 qtwebengine SDK generation fails

cancel
Showing results for 
Search instead for 
Did you mean: 

QT5 qtwebengine SDK generation fails

1,455 Views
Contributor I

Hi,

we are using a custom i.MX6SX design and like to develop / include a QT application based on qtwebengine.

Everything is fine so far and we are also able to ship and run the qtwebengine examples included with your yocto BSP.

Nevertheless for using QT Creator with an external toolchain we have to populate the SDK out of our yocto image.

Everything here is fine here except for when we start to include qtwebengine to the packagegroup-qt5-toolchain-target.bb. This step is required as otherwise the qtwebengine binary will be missing in the SDK and QT Creator will complain about that.

We are using the imx-morty branch of the i.MX yocto BSP. Also using custom machine, distro and image recipes but it will also fail when using the untouched BSP with the NXP machines / distros / images.

The problem can be triggered with either "bitbake -c populate_sdk image-name" or with "bitbake meta-toolchain-qt5".

See below and attachment for the error messages we are facing. Packages seems to be duplicated but we really cannot find the reason why.

When browsing the web for "yocto SDK generation" and "qtwebengine" you can see that at some point it was working. Most likely for any pre-morty releases.

Any tips for how to proceed?

Thanks,

Philip.

error: package qt3d-dbg-5.8.0+git0+440589a074-r0.cortexa9hf_neon is already installed

error: package volatile-binds-dbg-1.0-r0.all is already installed

error: package qtbase-dbg-5.8.0+git0+49dc9aa409-r0.cortexa9hf_neon_mx6sx is already installed

error: package libqt5sensors-dbg-5.8.0+git0+1220a31e6c-r0.cortexa9hf_neon is already installed

error: package qttranslations-5.8.0+git0+c0ae29b232-r0.cortexa9hf_neon is already installed

error: package coreutils-dbg-8.25-r0.cortexa9hf_neon is already installed

error: package qtgraphicaleffects-5.8.0+git0+1583bb5569-r0.cortexa9hf_neon is already installed

error: package kbd-dev-2.0.3-r0.cortexa9hf_neon is already installed

error: package gobject-introspection-dbg-1.48.0-r0.cortexa9hf_neon is already installed

error: package libical-dbg-2.0.0-r0.cortexa9hf_neon is already installed

error: package xz-dbg-5.2.2-r0.cortexa9hf_neon is already installed

error: package libnss-mdns-dev-0.10-r7.cortexa9hf_neon is already installed

error: package procps-3.3.12-r0.cortexa9hf_neon is already installed

error: package gcc-runtime-dbg-6.2.0-r0.cortexa9hf_neon is already installed

error: package packagegroup-core-standalone-sdk-target-dev-1.0-r8.all is already installed

error: package systemd-compat-units-dbg-1.0-r29.cortexa9hf_neon is already installed

error: package os-release-dbg-1.0-r0.all is already installed

error: package systemd-compat-units-dev-1.0-r29.cortexa9hf_neon is already installed

... and many more similar errors. See attachment for full log.

Labels (3)
Tags (2)
3 Replies

167 Views
Contributor I
 
I checked that we built qt on all backend of4.1.15, but not built qtwebengine on fb backend, only xwayland, so couldn't say if qtwebengine works on fb backend, since you built fb, don't have qtwebengine, pls try to built xwayland, we have tested on that. 
 

you can try

使用xwayland重新编译bsp
DISTRO=fsl-imx-xwayland MACHINE=imx6qsabresd source fsl-setup-release.sh -b build-xwayland
 
bitbake fsl-image-qt5
bitbake -c populate_sdk meta-toolchain-qt5

 

0 Kudos

132 Views
Contributor I

I have test, the problem still exist。

have you solved?

 

0 Kudos

204 Views
Contributor I

Hey Philip,

I was having the same issues you describe, and just stumbled upon something that works and wanted to mention it in case it helps you out too. I had seen that QtWebKit had been deprecated, and for Qt 5.8.0 you had to use QtWebEngine instead, and had been trying to generate an SDK while adding those to packagegroup-qt5-toolchain-target.bb and getting the errors. I happened to find towards the top of the file a mention of qtwebkit, and decided to try adding qtwebkit just to see what happens, and it ended up working out, so now I have a qt app that loads a webview using the webkit. Again, not sure why the webkit works, as it was supposedly removed from some version prior to the version of Qt I'm running. Here's what I did to get a build (I know that there might be some minor differences between our configurations that could still cause it to fail, but fingers crossed...):

Added the following lines to (sources/meta-qt5/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb):

qtwebkit \
qtwebkit-dev \
qtwebkit-mkspecs \

All at the end of the RDEPENDS_${PN} section (near the end of the file).

Also along the way of trying to figure this out, I added the following to (sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/images/fsl-image-qt5.bb) at the end of the file:

inherit populate_sdk_qt5

Honestly not sure if that had anything to do with it working, but thought I'd mention it in case it were needed.

After building the sdk, I reinstalled it, and qt now finds the webkit and webkitwidgets as valid imports in the project file (QT += webkit webkitwidgets) when using the qmake from the sdk.

Hope that helps!

Will