Problem with galcore

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with galcore

347 Views
alexberenshtein
Contributor III

Hi.
I have Kernel 4.1.15 + File System "Jetro" ( 2015 ) - module galcore.ko working OK , no problem with "insmod galcore.ko"
I did update to kernel 4.1.52 + File System "Jetro" ( 2015 ) - module galcore.ko working OK , no problem with "insmod galcore.ko"
Next step:
I compiled 2 version galcore.ko ( external module ) - with kernel 4.1.52 & kernel 4.14.98 & File System "Sumo" ( 2019 / 4.14.98 ) & I have the same problem:


If I use version from kernel 4.1.52 - I get a message - problem with version.
If I use version from kernel 4.14.98 - I get a message - problem with version.

Please help.
Best regards.

Labels (1)
0 Kudos
2 Replies

169 Views
alexberenshtein
Contributor III

Hi.
About problem with galcore driver:

Did I understand correctly - versions Kernel must match one another version FS (BSP), for example:

Kernel 4.14.98 + FS "Sumo" (4.14.98 ) ?
Kernel 4.1.15 + FS "Jetro" ( 4.1.15 ) ?

Best regards.

0 Kudos

169 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello Alex,

You don´t have to compile galcore in L4.14.98 since this is a BSP version, you must have galcore present. Please remove everything and download the BSP again.

For the 4.1.52 I don´t understand you say it work and the you said it doesn´t. However this is not kernel version supported.

Regards

0 Kudos