OpenGL GLX extension to be checked

cancel
Showing results for 
Search instead for 
Did you mean: 

OpenGL GLX extension to be checked

452 Views
sandeep_rai
Contributor II

OpenGL GLX extension is not supporting for hdmi display connected on im8qxp....

 

I ahve written a sample code based on glut...and run as following

freeglut (./sample): OpenGL GLX extension not supported by display ':0.0'

$Display was set to 0.0 and multiple...

How to change display enviroment for OpenGL GLX extension, that works for this board...Linux-4.14.87+?

0 Kudos
2 Replies

277 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello Sandeep,

You might find different errors in that code because the freeglut is not installed correctly,  however the HDMI display is EXPORT DISPLAY:0

Regards

0 Kudos

277 Views
sandeep_rai
Contributor II

FreeGlut binary are by-default installed to /usr/lib/ as libglut.so.x, libgl.so.x, libglu.so.x {glut dependency} and was unavailable .h files for glu, gl, and glut as include<GL/gl.h>, and glu.h, and glut.h but I resolved this using copying those header file from its yocto seems in yocto it was not by default instlled. But, any way when I compile the sample code based on glut in .cpp, I faced no error, but on run time i found this error: OpenGL GLX extension not supported by display ':0'    [DISPLAY=:0]

It is related to OpenGL  GLX error, seems GLX is not supporting. Alternate method, I have also used pyopengl for same but it also omitting same error.

Is GLX support HDMI DISPLAY?

IS GLX require another dependency like mesa-util, but in our case there is no mesa on yocto build or no available on Library in board file system related mesa?

Problem is at run time so I think, is there any issue related configuration for display, same code is running in Ubuntu/other PC?

Can You provide some Porting guide related to GLUT for this board?

0 Kudos