ONNXRUNTIME do_configure occurred error about flake8

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ONNXRUNTIME do_configure occurred error about flake8

563 Views
coindu
Contributor IV

  Hi:

             My linux environment is ubuntu 18.04 64bit. When I download L5.10.9 BSP and attempt to compile imx-image-full. I find the onnxruntime recipes can not compile. 

            The error  occur do_configure stage and below is the error. 

| -- Performing Test HAS_TAUTOLOGICAL_POINTER_COMPARE
| -- Performing Test HAS_TAUTOLOGICAL_POINTER_COMPARE - Failed
| -- Performing Test HAS_CATCH_VALUE
| -- Performing Test HAS_CATCH_VALUE - Success
| -- Performing Test HAS_MISSING_BRACES
| -- Performing Test HAS_MISSING_BRACES - Success
| -- Performing Test HAS_IGNORED_ATTRIBUTES
| -- Performing Test HAS_IGNORED_ATTRIBUTES - Success
| -- Performing Test HAS_DEPRECATED_COPY
| -- Performing Test HAS_DEPRECATED_COPY - Success
| -- Performing Test HAS_DEPRECATED_DECLARATIONS
| -- Performing Test HAS_DEPRECATED_DECLARATIONS - Success
| -- Performing Test HAS_CLASS_MEMACCESS
| -- Performing Test HAS_CLASS_MEMACCESS - Success
| -- Performing Test HAS_MAYBE_UNINITIALIZED
| -- Performing Test HAS_MAYBE_UNINITIALIZED - Success
| -- Looking for clock_gettime in rt
| -- Looking for clock_gettime in rt - found
| -- The ASM compiler identification is GNU
| -- Found assembler: /home/duxy/L5.10.9/build-xwayland/tmp/work/cortexa53-crypto-poky-linux/onnxruntime/1.5.3-r0/recipe-sysroot-native/usr/bin/aarch64-poky-linux/aarch64-poky-linux-gcc
| CMake Warning at flake8.cmake:19 (message):
| Could not find 'flake8' to check python scripts. Please install flake8
| using pip.
| Call Stack (most recent call first):
| CMakeLists.txt:1449 (include)
|

        Can anyone tell me how to solve this problem.  Refer to the attachment for all logs

 

0 Kudos
2 Replies

549 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

You need install flake8 on your ubuntu.

0 Kudos

545 Views
coindu
Contributor IV

         It is not work,Because It will use recipe-sysroot-native and recipe-sysroot floder tools to compile package. but both of them leak flake8 or python-flakes8.

sss@18.04:~@python3

Python 3.6.9 (default, Jun 29 2022, 11:45:57)
[GCC 8.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import flake8
>>> exit()
duxy@myir_server:~$ which flake8
/usr/local/bin/flake8

0 Kudos