Not getting console during boot I.MX6UL

cancel
Showing results for 
Search instead for 
Did you mean: 

Not getting console during boot I.MX6UL

372 Views
patrickchellasa
Contributor I

Hi,

       

I am using the NXP provided MfgTool to flash the image into our eMMC storage. The debug port in our design is mapped to UART5, while the debug port in the reference design is based on UART1. So when I try to use the MfgTool to flash the image, nothing was coming to the console. So we have modified the u-boot and mapped the debug port from UART1 to UART5 into the u-boot code and rebuild the image and now I see the u-boot logs coming to the console.

 

What I observe here is, u-boot is trying to load the image and it is trying to jump to the kernel. We have updated the device tree file also to reflect the debug console port settings. But unfortunately, we don’t see anything to the console when the kernel is booting. As a result, we are not in a position to debug any further. 

Thanks and regards,

P.Patrick.

Labels (1)
0 Kudos
3 Replies

196 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Patrick

was mfg tool firmware rebuilt (files in mfg tool /firmware folder) with

new console iomux settings, additionally it is necessary to replace ddr

setting in uboot/board/freescale/mx6ul_14x14_evk/imximage.cfg

found from ddr test

imximage.cfg\mx6ul_14x14_evk\freescale\board - uboot-imx - i.MX U-Boot 

i.MX6/7 DDR Stress Test Tool V2.92 

For rebuilding mfg tool firmware one can folow sect.6.2 Manufacturing Tool, MFGTool

attached Linux Guide.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

196 Views
patrickchellasa
Contributor I

This is the first step which we have already done. The following are the list of things which we have done.

 

  1. Changed imximage.cfg to reflect the new device config settings.
  2. Changed the debug console port mapping from UART1 to UART5 in u-boot code.

 

Only after these 2 changes, we were able to see u-boot logs coming to the console.

 

The current issue is, at the end of u-boot operation, the control will jump from u-boot to linux kernel. Here we see that no logs are dumped to the console from kernel. So we made changes in the device tree file to reflect the new debug port as UART5 and compiled and used the new .dtb file here. So, ideally I should see all logs being redirected to the console, which I am not seeing.

0 Kudos

196 Views
igorpadykov
NXP TechSupport
NXP TechSupport

if you are using MfgTool to flash the image these changes are not sufficient.

Mfg tool firmware (fsl-image-mfgtool-initramfs-imx_mfgtools.cpio.gz.u-boot) should be rebuilt

(file in mfg tool /firmware folder), these files are not the same as image (uboot/kernel/rootfs)

which you already changed.

Best regards
igor

0 Kudos