NFS booting setup for QSB

cancel
Showing results for 
Search instead for 
Did you mean: 

NFS booting setup for QSB

853 Views
jk1z
Contributor I

Dear All,

I have taken the source code of linux kernel, uboot and rootfs (dir structure) and compiled separately without using LTIB. It is compiled successfully and booting is success using micro SD card. When I try to use the NFS booting, kernel panic error is thrown.

IP-Config: Got DHCP answer from 0.0.0.0, my address is 10.0.30.27
IP-Config: Complete:
device=eth0, addr=10.0.30.27, mask=255.255.254.0, gw=10.0.31.220,
host=10.0.30.27, domain=nimbeon3.com, nis-domain=(none),
bootserver=0.0.0.0, rootserver=10.0.30.170, rootpath=
Looking up port of RPC 100003/3 on 10.0.30.170
Looking up port of RPC 100005/3 on 10.0.30.170
Root-NFS: Server returned error -13 while mounting 10.0.30.170:/home/openrd/jk/imx53/source/rootfs
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0)
Please append a correct "root=" boot option; here are the available partitions:
b300 3872256 mmcblk0 driver: mmcblk
b301 3544608 mmcblk0p1
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
[<8003711c>] (unwind_backtrace+0x0/0xe0) from [<803da040>] (panic+0x68/0xdc)
[<803da040>] (panic+0x68/0xdc) from [<80008de4>] (mount_block_root+0x1bc/0x1fc)
[<80008de4>] (mount_block_root+0x1bc/0x1fc) from [<80009038>] (prepare_namespace+0x120/0x174)
[<80009038>] (prepare_namespace+0x120/0x174) from [<80008a3c>] (kernel_init+0x120/0x160)
[<80008a3c>] (kernel_init+0x120/0x160) from [<800338b4>] (kernel_thread_exit+0x0/0x8)

Kindly suggest how to resolve this, I have modified the uboot boot parameters also referred the 

http://imxcommunity.org/forum/topics/imx51-kernel-panic-while?commentId=4103961%3AComment%3A6911 post. But not working.

regards,

jk

Labels (1)
0 Kudos
3 Replies

128 Views
jk1z
Contributor I

Hi wolfgang,

i have changed the nfsroot param and restarted the nfs server, it works.

Thanks for the help.

regards,

jk

0 Kudos

128 Views
jk1z
Contributor I

Hi wolfgang,

I have exported the path of nfs server. Below is the 'showmount' command output

[root@localhost ~]# showmount -e 10.0.30.170
Export list for 10.0.30.170:
/tftpboot *
/home/openrd/jk/imx53/source/rootfs *
/home/openrd/nfs/USB *
/home/openrd/nfs/debian_squeeze *
/home/openrd/nfs/rootfs *
[root@localhost ~]#

I will update the nfsroot variable and let you know.

rgds,

jk

0 Kudos

128 Views
WolfgangW
Contributor I

Hello jk,

> Root-NFS: Server returned error -13 while mounting 10.0.30.170:/home/openrd/jk/imx53/source/rootfs

from errno_base.h: #define EACCES 13 /* Permission denied */

It seems you either have

- /home/openrd/jk/imx53/source/rootfs not exported

- forgot no_root_squash as an export option

- any other NFS server setup problem I can not think about right now ;-)

Could you post the corresponding line of /etc/exports or show the result of "showmount -e localhost" on the NFS server?

Best regards
Wolfgang

PS: Another thing I noticed only after posting the first answer: In your kernel command line, there is "nfsroot=10.0.30.170:10.0.30.170:/home/openrd/jk/imx53/source/rootfs,v3,tcp" - try removing the ip from u-boot nfsroot variable, because it also gets prepended automatically from serverip?

0 Kudos