Multiple Display Support for imx8qxpmek

cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple Display Support for imx8qxpmek

1,063 Views
muhammed_ali
Contributor I

Hi,

        We have imx8qxpmek board hear, and we installed fsl-image-qt5-validation-imx(4.9.88_2.2.0_8qxp_beta2) image on that board. We need to display the qt applications on multiple Display. we connected two HDMI Displays connected on LVDS/MIPI  ports and getting Xwayland display. we need to run separate Qt application on each display,  But we couldn't able to select the display separately. could you please help on this ?.

           We have already tried exporting DISPLAY parameter on console and we are able to display Qt sample application on display connected to LVDS1 interface until reboot, we follow the same steps after reboot/power off but we couldn't able to display Qt application on LVDS1 interface as before.

0 Kudos
9 Replies

367 Views
joanxie
NXP TechSupport
NXP TechSupport

do you need to display LVDS+HDMI? did you set uboot command correctly?

0 Kudos

367 Views
muhammed_ali
Contributor I

Hi Joan Xie,

      We have Two HDMI Displays each of them connected to imx8qxpmek LVDS/DSI Port through ADV7535 bridge(LVDS to HDMI Converter). We did not set any uboot command. We gone through the documents but we couldn't find anything regarding uboot settings for multiple display. If there is any uboot command settings is needed please let us know.

0 Kudos

367 Views
joanxie
NXP TechSupport
NXP TechSupport

what image do you use? try to use "fsl-imx8qxp-mek.dtb"

0 Kudos

367 Views
muhammed_ali
Contributor I

We are using fsl-image-qt5-validation-imx image. we are using fsl-imx8qxp-mek.dtb as the fdt file.

We Could able to get Xwayland display on both the HDMI Display connected on LVDS0 and LVDS1 interfaces as mentioned earlier. the problem we are facing is to display different applications on two different displays. For Example: video playing on one display and qt application running on another display or two different video playing on two different displays

0 Kudos

367 Views
joanxie
NXP TechSupport
NXP TechSupport

refer to the known issue in the relase note of 4.9.88_2.2.0_8qxp_beta2:

Multi-instance playback and record are not supported.

but I checked L4.14.78-1.0.0_ga, I don't find this issue, so could you test L4.14.78-1.0.0_ga version?

i.MX 8QuadXPlus Multisensory Enablement Kit|NXP 

0 Kudos

367 Views
muhammed_ali
Contributor I

I am able to run L4.14.78-1.0.0_ga on imx8qxpmek, unfortunately i am getting the same result as 4.9.88_2.2.0_8qxp_beta2 image on the case of multiple display. could you please provide the steps you followed to run two application on two display.

0 Kudos

367 Views
joanxie
NXP TechSupport
NXP TechSupport

could you share your test steps? did you refer to the user guide as below?

7.3.1.6.1 Playing different videos on different displays
The command line to play two videos on different displays might look like this:
$GSTL $PLAYBIN uri=file:///$file1 playbin uri=file:///$file2 video-sink="overlaysink
display-master=false display-slave=true"

0 Kudos

367 Views
muhammed_ali
Contributor I

The Tested Steps are given below :

Tested BSP : 4.9.88_2.2.0_8qxp_beta2

Tested Image :  fsl-image-qt5-validation-imx

  • Connected two HDMI Display on two LVDS to HDMI Daughter Card
  • exported Display variable to select display
    • export DISPLAY=:0.0
  • executed Qt Appplication
    • ./Qt5_CinematicExperience

Qt Application works on the LVDS0 Display.

  • changed display variable to check whether it could switch the display
    • export DISPLAY=:0.1
  • executed Qt Application
    • ./Qt5_CinematicExperience

But unfortunately it is not working. the application still display on LVDS0 Display.

I have tested the command line to play two videos on different displays on  L4.14.78-1.0.0_ga as per the user guide, but it is also not working, the log is given below

Log :

WARNING: erroneous pipeline: could not set property "video-sink" in element "playbin1" to "overlaysink display-master=false display-slave=true".

0 Kudos

367 Views
joanxie
NXP TechSupport
NXP TechSupport

I tested on the imx8M successfully, pls try the command as below on your board

gst-launch-1.0 playbin uri=file:///test1.mp4 playbin uri=file:///test2.mp4 video-sink="glimagesink display-master=false display-slave=true"

 

0 Kudos