MFG Tool with USB3

cancel
Showing results for 
Search instead for 
Did you mean: 

MFG Tool with USB3

283 Views
matt67
Contributor III

Hello,

I am using the MFGTool2 in version 2.1.1 in order to load imx6DL products and the RAM rootfs is quiet large (14MB) because I embedded some test tools.

What I noticed is that, on USB3 the loaading failed at 75%, but succeed on USB2 port.

If I change my rootfs to a smaller one (4MB) whatever I use USB2 or USB3 port the dowload is fine.

Here is my ucl2.xml file:

<UCL>
<CFG>
<STATE name="BootStrap" dev="MX6D" vid="15A2" pid="0061"/>
<STATE name="Updater" dev="MSC" vid="0525" pid="A4A5"/>
</CFG>
<!--
The following Lists are for i.MX6Solo/DualLite chips
-->

<LIST name="i.MX6DL-PRODUCT-bootstrap" desc="PRODUCT - bootstrap">
<CMD state="BootStrap" type="boot" body="BootStrap" file ="gateway/Mfg/u-boot-PRODUCT-mfg-2GB.imx" >Loading U-boot</CMD>
<CMD state="BootStrap" type="load" file="gateway/Mfg/uImage.imx6dl-PRODUCT-2" address="0x10800000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" >Loading Kernel.</CMD>
<CMD state="BootStrap" type="load" file="gateway/Mfg/rootfs.cpio.uboot" address="0x11000000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" >Loading Initramfs.</CMD>
<CMD state="BootStrap" type="jump" > Jumping to OS image. </CMD>
</LIST>

</UCL>

Thank you,

0 Kudos
3 Replies

164 Views
b36401
NXP TechSupport
NXP TechSupport

Please try to use another cable. Possibly cable quality is enough for USB2 but not for USB3.

Have a great day,
Victor

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

164 Views
matt67
Contributor III

Hello,

We have found the cause of the problem, the USB port used on the loader pc is very slow  and the watchdog on our hardware design reset the product while loading.

The bootstrap phase takes about 1 min on this port. On other pc we tested its about 6 seconds or more.

Is there something in MFG tool or on the pc to set to optimize the hid bootstrap loading phase of MFG tool ?

Do you have 

0 Kudos

164 Views
matt67
Contributor III

Hi Victor,

We tried many cable, but we still have the problem on our factory bench computer.

Even on USB2 sometimes we got some fails.

Any idea ? We are blocked with this problem !

Thank you

0 Kudos