Loading DTB

cancel
Showing results for 
Search instead for 
Did you mean: 

Loading DTB

2,378 Views
emintolgasivri
Contributor II

Hi

I am using imx7d.I created new dts file and dtb file.I loaded dtb file to emmc .When I changed dtb file in boot below command I get these error message

=>setenv fdt_file imx7dea-ucom-kit-eclipse-ethernet.dtb
=>saveenv

Saving Environment to MMC...
Writing to MMC(1)... done

=>boot

switch to partitions #0, OK
mmc1(part 0) is current device
switch to partitions #0, OK
mmc1(part 0) is current device
reading boot.scr
1492 bytes read in 12 ms (121.1 KiB/s)
Running bootscript from mmc ...
## Executing script at 80800000
reading imx7dea-ucom-kit-eclipse-ethernet.dtb
0 bytes read in 13 ms (0 Bytes/s)
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
reading zImage
7447024 bytes read in 180 ms (39.5 MiB/s)
Kernel image @ 0x80800000 [ 0x000000 - 0x71a1f0 ]
ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree
Error loading kernel image

if I use orginal dtb file(imx7dea-ucom-kit) it is working.How can I fix this?

Tags (2)
3 Replies

1,308 Views
emintolgasivri
Contributor II

Hi gusarambula

I created my dtb file with make or make dtbs commands.

0 Kudos

1,308 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Emin Tolga Sivri,

There seems to be a problem with the compiled device tree, as it is marking reading imx7dea-ucom-kit-eclipse-ethernet.dtb and reading 0 bytes.

How are you generating the device tree? My recommendation would be adding it to the makefile and using make to compile it alongside the rest of the device tree on the BSP.

I hope this information helps,

Regards,

1,308 Views
emintolgasivri
Contributor II

Hi gusarambula

 

I created my dtb file with make or make dtbs commands.Also it is 44KB.

0 Kudos