Linux build issue (L3.0.35_4.0.0)

cancel
Showing results for 
Search instead for 
Did you mean: 

Linux build issue (L3.0.35_4.0.0)

Jump to solution
3,588 Views
keitanagashima
Senior Contributor I

Dear Sir or Madam,

 

Hello.

I couldn't build the Linux BSP (L3.0.35_4.0.0).


Board: MX6DL SABRE-SDP

BSP: L3.0.35_4.0.0

Host PC: Ubuntu 9.04

I referred to Setting_Up_LTIB_Host.pdf and i.MX_6Solo6DualLite_Sabre-SDP_Linux_User_Gudie.pdf

 

I tried this command : "./ltib -m config"

But, the build failed.

Refer to attached error log and please tell me advice.


Keita

Original Attachment has been moved to: host_config.log.zip

Labels (1)
Tags (2)
0 Kudos
1 Solution
314 Views
keitanagashima
Senior Contributor I

Dear All,

Thank you for your support.

Build succeeded!

I describe my procedure.

=====

[Environment]

Board: MX6DL SABRE-SDP

BSP: L3.0.35_4.0.0

Host PC: Ubuntu 12.04

Virtual Box: 4.2.10

[Install package for LTIB]

sudo aptitude -y install gettext libgtk2.0-dev rpm bison m4 libfreetype6-dev

sudo aptitude -y install libdbus-glib-1-dev liborbit2-dev intltool

sudo aptitude -y install ccache ncurses-dev zlib1g zlib1g-dev gcc g++ libtool

sudo aptitude -y install uuid-dev liblzo2-dev

sudo aptitude -y install tcl dpkg

sudo apt-get install texinfo

sudo apt-get install texlive

[Remove directory]

sudo rm -Rf /opt/freescale/ltib/usr/src/rpm/BUILD/flex-2.5.37

sudo rm -Rf /opt/freescale/ltib/usr/src/rpm/BUILD/libtool-2.4.2

[Change the ltib script]

sudo vi ~ltib/ltib

Comment out (#) the line as shown below in ltib script.

Package                Minimum ver   Installed info

-------                -----------   ---------------

#zlib                   0             not installed

=====

Keita

View solution in original post

0 Kudos
9 Replies
315 Views
keitanagashima
Senior Contributor I

Dear All,

Thank you for your support.

Build succeeded!

I describe my procedure.

=====

[Environment]

Board: MX6DL SABRE-SDP

BSP: L3.0.35_4.0.0

Host PC: Ubuntu 12.04

Virtual Box: 4.2.10

[Install package for LTIB]

sudo aptitude -y install gettext libgtk2.0-dev rpm bison m4 libfreetype6-dev

sudo aptitude -y install libdbus-glib-1-dev liborbit2-dev intltool

sudo aptitude -y install ccache ncurses-dev zlib1g zlib1g-dev gcc g++ libtool

sudo aptitude -y install uuid-dev liblzo2-dev

sudo aptitude -y install tcl dpkg

sudo apt-get install texinfo

sudo apt-get install texlive

[Remove directory]

sudo rm -Rf /opt/freescale/ltib/usr/src/rpm/BUILD/flex-2.5.37

sudo rm -Rf /opt/freescale/ltib/usr/src/rpm/BUILD/libtool-2.4.2

[Change the ltib script]

sudo vi ~ltib/ltib

Comment out (#) the line as shown below in ltib script.

Package                Minimum ver   Installed info

-------                -----------   ---------------

#zlib                   0             not installed

=====

Keita

View solution in original post

0 Kudos
314 Views
Yuri
NXP TechSupport
NXP TechSupport

Perhaps it makes sense to try recent Ubuntu / Debian releases as a host OS.

i.MX Linux BSP Environment Setup

0 Kudos
314 Views
LeonardoSandova
Specialist I

According to the log, you need to install the texi2dvi before running ltib.

/bin/sh: texi2dvi: command not found

make[2]: *** [flex.pdf] Error 127

make[2]: Leaving directory `/opt/freescale/ltib/usr/src/rpm/BUILD/flex-2.5.37/doc'

make[1]: *** [install-recursive] Error 1

make[1]: Leaving directory `/opt/freescale/ltib/usr/src/rpm/BUILD/flex-2.5.37'

make: *** [install] Error 2

error: Bad exit status from /home/guest/ltib/tmp/rpm-tmp.29045 (%install)

Leo

314 Views
keitanagashima
Senior Contributor I

Dear Leo,

Hello.

I tried to command of "sudo apt-get install texi2dvi"

But, it couldn't get the texi2dvi package.

And, I tried to build again.

./ltib -m distclean

./ltib

Check the following error log.

Processing platform: Host support packages

============================================

using /home/guest/ltib/config/platform/host/ltib.preconfig

Processing: fake-provides

===========================

Processing: mkspooflinks

==========================

Processing: distcc

====================

Processing: ccache

====================

Processing: m4

================

Processing: bison

===================

Processing: flex

==================

Build path taken because: directory build, no prebuilt rpm,

Cowardly refusing to clobber existing directory:

/opt/freescale/ltib/usr/src/rpm/BUILD/flex-2.5.37

Remove this by hand if you really want to rebuild this package from scratch

Died at ./ltib line 1392.

traceback:

main::build_host_rpms:1392

  main::host_checks:1447

   main:554

Started: Tue Jul 30 09:40:44 2013

Ended:   Tue Jul 30 09:40:45 2013

Elapsed: 1 seconds

These packages failed to build:

flex

Build Failed

===

Keita

0 Kudos
314 Views
LeonardoSandova
Specialist I

Keita,

in case the app you are trying to install is not found, you need to figure out which packages installs the app. Google is your friend, but also the app 'apt-file' (if you do not have it, install it) is. Once installed it you can try:

$ apt-file find texi2dvi

a2ps: /usr/bin/texi2dvi4a2ps

a2ps: /usr/share/man/man1/texi2dvi4a2ps.1.gz

manpages-ja: /usr/share/man/ja/man1/texi2dvi.1.gz

manpages-zh: /usr/share/man/zh_CN/man1/texi2dvi.1.gz

manpages-zh: /usr/share/man/zh_TW/man1/texi2dvi.1.gz

texinfo: /usr/bin/pdftexi2dvi

texinfo: /usr/bin/texi2dvi

texinfo: /usr/share/man/man1/pdftexi2dvi.1.gz

texinfo: /usr/share/man/man1/texi2dvi.1.gz

texinfo-doc-nonfree: /usr/share/doc/texinfo/html/Format-with-texi2dvi.html

texlive-pictures-doc: /usr/share/doc/texlive-doc/support/texdraw/texi2dvi.gz

texlive-pictures-doc: /usr/share/doc/texlive-pictures-doc/support/texdraw/texi2dvi.gz

as you can see, the texinfo package (as suggested by Hemal), is the one you need to install.

Leo

0 Kudos
314 Views
keitanagashima
Senior Contributor I

Hi Leo,

I could see following by apt-file find texi2dvi.

a2ps: /usr/bin/texi2dvi4a2ps

a2ps: /usr/share/man/man1/texi2dvi4a2ps.1.gz

manpages-ja: /usr/share/man/ja/man1/texi2dvi.1.gz

manpages-zh: /usr/share/man/zh_CN/man1/texi2dvi.1.gz

manpages-zh: /usr/share/man/zh_TW/man1/texi2dvi.1.gz

r-base-core: /usr/lib/R/library/tools/help/texi2dvi

r-base-html: /usr/lib/R/library/tools/html/texi2dvi.html

r-base-latex: /usr/lib/R/library/tools/latex/texi2dvi.tex

texinfo: /usr/bin/texi2dvi

texinfo: /usr/share/man/man1/texi2dvi.1.gz

texinfo-doc-nonfree: /usr/share/doc/texinfo/html/Format-with-texi2dvi.html

texlive-pictures-doc: /usr/share/doc/texlive-doc/texdraw/texi2dvi.gz

texlive-pictures-doc: /usr/share/doc/texlive-pictures-doc/texdraw/texi2dvi.gz

I had already installed the texinfo package.

But, the texlive package couldn't be installed by sudo apt-get install texlive (as suggested by Hemal).

When I install the texlive, dpkg of package management system was broken...

Keita

0 Kudos
314 Views
Yuri
NXP TechSupport
NXP TechSupport

Are old repos applied, as recommended in section 1.2 (Update Sources.list to Point to Old-releases Repository) of "Setting_Up_LTIB_Host.pdf"

0 Kudos
314 Views
hemalgandhi
Contributor III

Hi Keita

Install below package can fix the error

sudo apt-get install texinfo

sudo apt-get install texlive

if you need more info please refer below link.

https://community.freescale.com/message/314749#314749

Regards,

Hemal

314 Views
keitanagashima
Senior Contributor I

Hi Hemal,

I tried to below command.

sudo apt-get install texinfo

sudo apt-get install texlive

When I install the texlive, dpkg of package management system was broken...

So, I repair the /etc/texmf/fmt.d/10texlive-latex-base.cnf.

(The following are out of comments.)

#latex           pdftex         language.dat-translate-file=cp227.tcx *latex.ini

#pdflatex      pdftex          language.dat-translate-file=cp227.tcx *pdflatex.ini

And, using command of "sudo dpkg --configure -a"

But, LTIB couldn't build the BSP.

Keita

0 Kudos