LTIB Installation Failed

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LTIB Installation Failed

674 Views
harshadsinkar
Contributor I

I am trying to install LTIB on my Ubuntu machine and getting the following error:

```

$./install

You are about to install the LTIB (GNU/Linux Target Image Builder)

Before installing LTIB, you must read and accept the EULA
(End User License Agreement) which will be presented next.

Do you want to continue ? Y|n
Y

Hit enter to continue:
sh: 1: Syntax error: "(" unexpected

I have read and accept the EULA (yes|no):
yes
sh: 1: Syntax error: "(" unexpected
Use of uninitialized value $_ in pattern match (m//) at ./install line 139.
Cannot extract release tag at ./install line 140.

```

How to resolve this issue?

Any help is appreciated.

Tags (3)
0 Kudos
3 Replies

486 Views
Yuri
NXP Employee
NXP Employee

Hello,

"Building for i.MX Mature Boards"

https://www.nxp.com/docs/en/application-note/AN12024.pdf

Regards,

Yuri.

0 Kudos

486 Views
fabio_estevam
NXP Employee
NXP Employee

Hi Harshad,

LTIB is no longer supported. Please use a recent build tool, such as Yocto or Buildroot.

Regards,

Fabio Estevam

0 Kudos

486 Views
igorpadykov
NXP Employee
NXP Employee

Hi Harshad

please look at ltib installation hints on

Ubuntu 11.10 Oneiric 64-bit Virtual Machine and building i.MX53 L2.6.35-11-09-01 

AN3875 Building a Linux Image and Downloading onto i.MX Processors Using a Virtual Machine 

https://www.nxp.com/docs/en/application-note/AN3875.pdf 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos