Issue with adding OP-TEE support on i.MX 8MM venice

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issue with adding OP-TEE support on i.MX 8MM venice

Contributor I


I am having some troubles adding OP-TEE support to an i.MX8MM board. We are using the meta-freescale layer to provide optee recipes, along with a custom layer which provides a u-boot recipe.


I managed to get optee binaries installed, mainly using this presentation: The only thing left is getting /dev/tee* device to work, since for now it isn't even present. I tried to add a firmware node to the device tree in uboot-venice/arch/arm/dts/imx8mm.dtsi, and multiple other files in u-boot, but to no avail. I even checked that a .dtb file produced by yocto contains an optee node, but after booting the system it is not present.

I also tried inserting the firmware node to the system directly, in its own device tree, but then dmesg showed optee: api uid mismatch, which tells me that it should be added in u-boot.

Do you have any ideas what could be the cause of this problem?
Best regards,

0 Kudos
1 Reply

NXP Employee
NXP Employee

Hi Pawel,

For more details about the installation I share the i.MX Porting Guide, chapter 5 is the configuration of OP-TEE

And the OP-TEE documentation, in the build and run section


Best Regards,


0 Kudos