IMX6QualQuad SABRED

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IMX6QualQuad SABRED

2,870 Views
rayxianghoooo
Contributor I

Hi All, i'm installing and building LTIB by "i.MX 6Dual/6Quad SABRE-SD LinuxUser's Guide.pdf"  , when i run "./ltib -m config"  it shows :

------------------------------------------------------------------------------------------------------

For information about obtaining TeX, please see http://www.tug.org.  If

you happen to be using Debian, you can get it with this command:

  apt-get install tetex-bin

make[2]: *** [flex.pdf] Error 1

make[2]: Leaving directory `/opt/freescale/ltib/usr/src/rpm/BUILD/flex-2.5.37/doc'

make[1]: *** [install-recursive] Error 1

make[1]: Leaving directory `/opt/freescale/ltib/usr/src/rpm/BUILD/flex-2.5.37'

make: *** [install] Error 2

error: Bad exit status from /home/season/mx6/river/ltib/tmp/rpm-tmp.98666 (%install)

-----------------------------------------------------------------------------------------------------------------------

but when i run :sudo apt-get install tetex-bin  , it's

---------------------------------------------------------------------------

Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  tetex-bin: Depends: tetex-base (>= 3.0-4) but it is not going to be installed
             Depends: tex-common (>= 0.34) but it is not going to be installed
E: Broken packages

---------------------------------------------------------------------------------

hoe can i fix ti?

Labels (2)
0 Kudos
23 Replies

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi rayxiang,

It's  truly due to the old packages for Ubuntu 9.04. So the best method is to update the version of UBUNTU to 10.04 or 12.04. If you are using the newest BSP L3.0.35_4.1.0 . Then you have to set up linux environment according to the document "Setting Up LTIB host" in the docs (L3.0.35_4.1.0_..._docs).

Best Regards

Dan

0 Kudos

2,265 Views
florianl
Contributor III

Hi Dan!

But please, please offer official support then for the newer Ubuntu releases... At the moment it is a real pain to set up ltib on a fresh install of Ubuntu 10 or 11 or 12...

Or do you have ALL necessary patches for the setup at the newer Ubuntu versions? It would be great... or would you rather recommend to use YOCTO instead?

Best regards

Florian

0 Kudos

2,264 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi Florian,

And I am using Ubuntu 10.04, I think it's easy for me to use. Here I attach you document made by my colleague , it is not official document but you can reference it .

Hope this can help you~~

Best Regards

Dan

0 Kudos

2,265 Views
LeonardoSandova
Specialist I

Hi Florian,

I understand your frustration. One of the reasons we are moving to Yocto is that is less host-dependant, where you just need a few packages installed and all the rest Yocto (in fact, bitbake, the core engine) fetches and compiles. I would strongly suggest to move to Yocto; there are some documents out there to smooth the ramp-up.

Leo

2,264 Views
florianl
Contributor III

Thanks Leonardo! Which Distribution so you use Yocto on? Do You also build on Ubuntu? Or can you recommend another distro such as Fedora?

Do you have some good getting started guides for Yocto?

Thanks again.

Florian

0 Kudos

2,264 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi Florian,

Sorry to delay reply.  I haven't used the Yocto , so about the use of Yocto you can ask Leonardo or others for help.

Best Regards

Dan

0 Kudos

2,264 Views
LeonardoSandova
Specialist I

I am using Yocto on a Ubuntu 12.04 (32 and 64 bits), it works fine.

There are some tutorials on the community and of course outside, but as a staring point I would take this:

Yocto Training - HOME

Yocto takes lots of HD space, so make sure you got enough before baking!

Leo

0 Kudos

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi rayxiang,

You can do as maurice said, remove the Flex package and install texlive-base package by commend:  $sudo apt-get install texlive $sudo apt-get install texlive-base .

By the way, are you using the newest BSP ?  If not, you can have a try.


Best Regards

Dan

0 Kudos

2,265 Views
rayxianghoooo
Contributor I

Hi, Dan
I follow the commend sudo apt-get install texlive ,but it shows:

---------------------------------------------------------------------------------------------

prosper depends on texlive-latex-base; however:

  Package texlive-latex-base is not configured yet.

prosper depends on texlive-latex-recommended; however:

  Package texlive-latex-recommended is not configured yet.

dpkg: error processing prosper (--configure):

dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of texlive-humanities:

texlive-humanities depends on texlive-latex-base (>= 2007-11); however:

  Package texlive-latex-base is not configured yet.

dpkg: error processing texlive-humanities (--configure):

dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of tipa:

tipa depends on texlive-latex-base; however:

  Package texlive-latex-base is not configured yet.

dpkg: error processing tipa (--configure):

dependency problems - leaving unconfigured

Errors were encountered while processing:

texlive-latex-base

texlive-latex-recommended

texlive

texlive-latex-extra

texlive-math-extra

texlive-lang-cyrillic

texlive-xetex

dblatex

latex-xcolor

pgf

latex-beamer

prosper

texlive-humanities

tipa

E: Sub-process /usr/bin/dpkg returned an error code (1)

-------------------------------------------------------------------------------------------------------

what's that supposed to mean?

0 Kudos

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi rayxiang,

Sorry for the previous answer, and now I get the right solution.

When you run "./ltib -m config", error as you have mentioned above. As your BSP is L3.0.35_4.0.0_130424_source and UBUNTU is

ubuntu 12.04 x86_64

Install below package for LTIB can fix the error:

sudo apt-get install texinfo

sudo apt-get install texlive


Best Regards,

Dan

0 Kudos

2,265 Views
florianl
Contributor III

Hi Dan,

for me it's the same problem: I have everything set up like described in the last BSP Documentation. VM in VirtualBox with Ubuntu 9.04 and all package sources set up accordingly to your Document "Set Up LTIB Environment".

Then on installing prerequisites (packages as described in the Set Up Document) I get the same error messages!

Do you have a solution for this?

Thanks!

Florian

0 Kudos

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi Florian,

Would you mind telling me your BSP, L3.0.35_4.0.0 or L3.0.35_4.1.0 ?

You can have a try the commends:

sudo apt-get update

sudo apt-get -f install

You also can reference the documnet

i.MX Linux BSP Environment Setup


Best Regards

Dan

0 Kudos

2,265 Views
florianl
Contributor III

Hi there,

yes I set everything up as mentioned in this document - I'm using the latest Version of the BSP (L3.0.35_4.1.0). BUT, the problem was still there and I (or better a good friend) fixed this latex time bomb: Michael Dodl - LaTeX - Disabling the 5 year time bomb

Maybe you should add this as a patch to the getting started documents!!

0 Kudos

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi Florian,

OK. I will discuss with my team colleagues. Thanks.

Best Regards

Dan

0 Kudos

2,265 Views
florianl
Contributor III

By the way: There was somebody else who had this problem: Building the LTIB in iMX6 in linux bsp

Here again some detailed informations about my setup:

I had the same problem yesterday on a fresh install of Ubuntu 9.04 - I also wanted to use the latest BSP (L3.0.35_4.1.0_ER_SOURCE_BSP).

To reproduce my setup: I did everything mentioned in the "Setting Up LTIB host" in the docs (L3.0.35_4.1.0_..._docs) Package from the Freescale site.

The problem is indeed the old latex package for Ubuntu 9.04 - you can fix it after the failed setup by commenting out some lines in /usr/share/texmf-texlive/tex/latex/base/latex.ltx and running the installation again like mentioned in your "Setting Up LTIB host" - doc:

sudo aptitude -y install asciidoc texlive-latex-base dblatex xutils-dev

For more information about the problem please read this blog entry: http://my.opera.com/Michael-Dodl/blog/2011/06/24/latex-disabling-the-5-year-time-bomb

Hopefully it helps!

Best regards

Florian

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi Florian,

Thanks a lot for your useful advice. It's  truly due to the old packages for Ubuntu 9.04. So the best method is to update the version of UBUNTU to 10.04 or 12.04 .

Best Regards

Dan

0 Kudos

2,265 Views
carmilili
Contributor III

I have solved this problem.

sudo apt-get update

sudo apt-get -f install

0 Kudos

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi Carmili,


After you executing the commend :

sudo apt-get update

sudo apt-get -f install

have you run these two to solved the problem

sudo apt-get install texinfo

sudo apt-get install texlive

Thanks.


Best Regards

Dan

0 Kudos

2,265 Views
carmilili
Contributor III

Hi,Dan

It is not  necessary to run the command.

sudo apt-get install texinfo

sudo apt-get install texlive

0 Kudos

2,265 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi Camili,

OK. Thanks a lot.

Best Regards

Dan

0 Kudos