IMX6 quad plus display problem with HDMI

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX6 quad plus display problem with HDMI

177 Views
pung2516
Contributor I

Hi.

I am using IMX6 QuadPlus using Android SDcard booting with HDMI

i did all the settings such as 

""

U-Boot >   setenv fastboot_dev mmc1

   setenv bootcmd boota mmc1

   setenv bootargs console=ttymxc0,115200 androidboot.console=ttymxc0 consoleblank=0 vmalloc=128M init=/init    video=mxcfb0:dev=hdmi,1920x1080M@60,bpp=32 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off    androidboot.hardware=freescale cma=448M galcore.contiguousSize-33554432 androidboot.selinux=permissive

   saveenv

""

After those settings are done and boot again,

i cannot see the GUI from the monitor using HDMI. All i can see is just a black screen. 

I got the error msgs like below kinda related to surfaceflinger.rc

[ 28.589633] init: Failed to bind socket 'pdx/system/vr/display/client': No such file or directory
[ 28.590065] init: Failed to bind socket 'pdx/system/vr/display/manager': No such file or directory
[ 28.590554] init: Failed to bind socket 'pdx/system/vr/display/vsync': No such file or directory

have no idea what to do..

Need your help. Thanks

Labels (2)
0 Kudos
2 Replies

74 Views
b45499
NXP TechSupport
NXP TechSupport

From your above message it seems that your board can not read the screen. Which HDMI screen are you using?

0 Kudos

74 Views
b45499
NXP TechSupport
NXP TechSupport

About the HDMI display you can refer to our Android_Quick_Start_Guide document section:

3.4.2 Booting with single display: HDMI display
In the U-Boot prompt, set the U-Boot environment variables as shown below:
U-Boot > setenv bootcmd boota mmc2
U-Boot > setenv bootargs console=ttymxc0,115200 androidboot.console=ttymxc0 consoleblank=0
vmalloc=128M init=/init video=mxcfb0:dev=hdmi,1920x1080M@60,bpp=32 video=mxcfb1:off
video=mxcfb2:off video=mxcfb3:off androidboot.hardware=freescale cma=448M
galcore.contiguousSize=33554432 loop.max_part=7
U-Boot > saveenv
With the settings above, the Android platform does not start the shell console. To disable selinux, append
"androidboot.selinux=permissive" to the U-Boot's bootargs. Boot environment variables are as follows:
U-Boot > setenv append_bootargs androidboot.selinux=permissive
U-Boot > saveenv

0 Kudos