How to downgrade Qt version?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to downgrade Qt version?

1,723 Views
durmus
Contributor IV


Hi,

Freescale Yocto release L3.14.52_1.1.0_ga comes with Qt5 recipes for version 5.5.0.

What files should I modify to safely build a lower version (say 5.2.x)?

Thanks.

Labels (2)
Tags (4)
0 Kudos
1 Reply

794 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello,

If you want to change to Qt 5.2 I would recommend looking at the Qt image recipe and write a similar recipe with the equivalent Qt 5.2 packages. Unfortunately the BSPs do not hold on to older Qt recipes so there is not an easy out-of-the-box solution for this.

You may look at older BSPs, perhaps the L3.10.XX releases would better suit your needs and actually use Qt 5.2, if I recall correctly.

Regards,