How to disable DDR/BUS frequency scaling from kernel space?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to disable DDR/BUS frequency scaling from kernel space?

Jump to solution
417 Views
maxwellp
Contributor I

Hello,

I am creating a linux distribution using the yocto project that runs on an iMX6UL processor (Variscite DART6UL SOM in particular). Currently, at startup during runtime (via rc.local) the DDR/BUS frequency scaling gets disabled with the following command:

# Disable runtime power management to avoid deadlock

echo 0 > /sys/devices/soc0/soc/soc:busfreq/enable

Here we can see that DDR/BUS frequency scaling is being disabled from user space. I would like to make the distro use a read-only file system but disabling DDR/BUS frequency scaling from user space is preventing me from being able to do this. I can't simply just remove this statement because deadlock must be avoided.

How can I disable DDR/BUS frequency scaling from kernel space? If such a thing isn't possible, I am open to alternative approaches, maybe disabling via uboot somehow or something.

Labels (3)
0 Kudos
1 Solution
171 Views
karangajjar
Senior Contributor II

Hi Maxwell Pung ,

As mentioned in the section 2.3.4.2. of the document

https://www.nxp.com/docs/en/reference-manual/i.MX_Reference_Manual_Linux.pdf

There is no menu-configuration option for disabling the DDR/BUS frequency scaling.

But you can set bus_freq_scaling_is_active to 0 in "arch/arm/mach-imx/busfreq-imx.c" to disable DDR/BUS frequency scaling as shown in below link:

imx:busfreq: disable busfreq driver by default (ea53bf7f) · Commits · ARM / imx6_kernel_3.14 · GitLa... 

Let us know in case of any concern.

Regards,

Karan Gajjar.

View solution in original post

0 Kudos
2 Replies
172 Views
karangajjar
Senior Contributor II

Hi Maxwell Pung ,

As mentioned in the section 2.3.4.2. of the document

https://www.nxp.com/docs/en/reference-manual/i.MX_Reference_Manual_Linux.pdf

There is no menu-configuration option for disabling the DDR/BUS frequency scaling.

But you can set bus_freq_scaling_is_active to 0 in "arch/arm/mach-imx/busfreq-imx.c" to disable DDR/BUS frequency scaling as shown in below link:

imx:busfreq: disable busfreq driver by default (ea53bf7f) · Commits · ARM / imx6_kernel_3.14 · GitLa... 

Let us know in case of any concern.

Regards,

Karan Gajjar.

View solution in original post

0 Kudos
171 Views
maxwellp
Contributor I

Karan,

Thank you that patch is exactly what I was looking for.

~ Maxwell

0 Kudos