How to configure display on LVDS0 panel

cancel
Showing results for 
Search instead for 
Did you mean: 

How to configure display on LVDS0 panel

1,209 Views
rajucm
Contributor III

Hi all,

We got new version of hardware with imx6.

Here, LVDS0 ==(connected)==> ADV7123 to get RGB output.

Currently, we are able to see HDMI output

with bootargs=console=ttymxc0,115200 maxcpus=2 init=/init video=mxcfb0:dev=hdmi,720x480M@60,bpp=32 video=mxcfb1:off video=mxcfb2:off fbmem=28M vmalloc=400M androidboot.console=ttymxc0 androidboot.hardware=freescale

But, We need display for LVDS0. Please suggest me command line for LVDS0 configuration and code changes...

do I need to make changes in /video/mxc/ldb.c & arch\arm\mach-mx6\board-mx6q_sabresd.c ?

Please suggest me.

Thanks,

Raju

0 Kudos
5 Replies

210 Views
saurabh206
Senior Contributor III

Hi

Raju

You need to modified the boot args for video output to LVDS.

According to your required resolution you need modify the video/mxc/ldb.c

Thanks

Saurabh

0 Kudos

210 Views
rajucm
Contributor III

Hi Sourabh,

Thank you...

I tried command line following bootargs

setenv bootargs console=ttymxc0,115200 fb0base=0x27b00000 init=/init video=mxcfb0:dev=ldb,LDB-1080P60,if=RGB24,bpp=32 ldb=spl0 fbmem=28M,28M video=mxcfb1:dev=hdmi,1920x1080M@60,bpp=32 video=mxcfb2:off vmalloc=450M androidboot.console=ttymxc0 androidboot.hardware=freescale

@/video/mxc/ldb.c

static struct fb_videomode ldb_modedb[] = {

    {

     "LDB-WXGA", 60, 1280, 800, 14065,

     40, 40,

     10, 3,

     80, 10,

     0,

     FB_VMODE_NONINTERLACED,

     FB_MODE_IS_DETAILED,},

    {

     "LDB-XGA", 60, 1024, 768, 15385,

     220, 40,

     21, 7,

     60, 10,

     0,

     FB_VMODE_NONINTERLACED,

     FB_MODE_IS_DETAILED,},

    {

     "LDB-1080P60", 60, 1920, 1080, 7692,

     100, 40,

     30, 3,

     10, 2,

     0,

     FB_VMODE_NONINTERLACED,

     FB_MODE_IS_DETAILED,},

    {

     "43wvf1g", 60, 800, 480, 30303,

     88, 40,

     32, 13,

     48, 3,

     0,

     FB_VMODE_NONINTERLACED,

     FB_MODE_IS_DETAILED,},

    

With above changes I can see HDMI working fine but still LVDS not working.    

Do we need some more changes?

Thanks,

Raju

0 Kudos

210 Views
saurabh206
Senior Contributor III

Code change look ok.

Are you using Android or linux roofts?

0 Kudos

210 Views
rajucm
Contributor III

Hi sourabh,

we are using Android.....

I found little progress by with following commandline (LDB-1080P60 --to--> 43wvf1g).

setenv bootargs console=ttymxc0,115200 fb0base=0x27b00000 init=/init video=mxcfb0:dev=ldb,43wvf1g,if=RGB24,bpp=32 ldb=spl0 fbmem=28M,28M video=mxcfb1:dev=hdmi,1920x1080M@60,bpp=32 video=mxcfb2:off vmalloc=450M androidboot.console=ttymxc0 androidboot.hardware=freescale

Now, I am able to black screen (earlier no signal)...

Thanks

Raju

0 Kudos

210 Views
rajucm
Contributor III

Hi,

With above mentioned command line, I am getting either black or blue screen..

Do I need to change IPU id & Disp id?

static struct fsl_mxc_ldb_platform_data ldb_data = {

    .ipu_id = 0,

    .disp_id = 0,

    .ext_ref = 1,

    .mode = LDB_SIN0,

};

Please suggest me..

Thanks,

Raju

0 Kudos