How to add missing perl modules into yocto.

cancel
Showing results for 
Search instead for 
Did you mean: 

How to add missing perl modules into yocto.

Jump to solution
4,564 Views
arkceajin
Contributor I

Hello

I am trying to install Unix Bench into iMX6 Poky Yocto 1.6.2 . I successfully cross compiled Unix Bench source code. But  when i run Unix Bench, generated error said these 4 perl modules can not be found:

use POSIX qw(strftime);
use Time::HiRes;
use IO::Handle;
use FindBin;

So did i miss some thing while build the system?
Or any way to add these modules into yocto?

Thanks 

Labels (2)
Tags (2)
0 Kudos
1 Solution
2,456 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi ark

please check

How can I install missing perl modules on an embedded system? - Stack Overflow 

also this can be posted on to meta-fsl-arm mailing list, so that someone familiar with it could try to assist you.
https://lists.yoctoproject.org/listinfo/meta-freescale

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
2,457 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi ark

please check

How can I install missing perl modules on an embedded system? - Stack Overflow 

also this can be posted on to meta-fsl-arm mailing list, so that someone familiar with it could try to assist you.
https://lists.yoctoproject.org/listinfo/meta-freescale

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
2,456 Views
arkceajin
Contributor I

Hello igor

Thanks you for answering my question, I added the modules into local.conf and rebuild the yocto solved the problem.

Ark

0 Kudos