How to Install Lua in imx7dsabresd

cancel
Showing results for 
Search instead for 
Did you mean: 

How to Install Lua in imx7dsabresd

197 Views
Contributor III

Hi Everyone,

I need to run Lua script  in imx7 Board, can any one help me how to Install Lua libraries in Imx Board.

Thanks & Regards,

Prasad.

0 Kudos
2 Replies

65 Views
NXP TechSupport
NXP TechSupport

There are some Lua cross-compilers for ARM like this:
http://www.eluaproject.net/doc/v0.9/en_tc_arm.html
So you can compile your Lua code and get the binary you can run on target board.

Have a great day,
Victor

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

65 Views
Contributor III

Hi victor,

Thanks for your reply,

I tried the link that you provided for arm7, but i am getting error in binutils as

configure: loading site script /opt/fsl-imx-x11/4.9.88-2.0.0/site-config-cortexa7hf-neon-poky-linux-gnueabi
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... arm-unknown-elf
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for gcc... arm-poky-linux-gnueabi-gcc -march=armv7ve -mfpu=neon -mfloat-abi=hard -mcpu=cortex-a7 --sysroot=/opt/fsl-imx-x11/4.9.88-2.0.0/sysroots/cortexa7hf-neon-poky-linux-gnueabi
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: in `/home/linux-pc/binutils-2.19.50/build':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.

can you please help me to solve this issue.

0 Kudos