GStreamer - ValueError: Namespace GstRtspServer not available

cancel
Showing results for 
Search instead for 
Did you mean: 

GStreamer - ValueError: Namespace GstRtspServer not available

4,326 Views
imx_learner
Contributor I

Hi, 

I am trying to use gst-rtsp-server in my python application. for this I included the following : 

      import gi 
     gi.require_version('GstRtspServer','1.0') 
     from gi.repository import GstRtspServer 

However, I get the following error: 
  gi.require_version('GstRtspServer','1.0') 
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 130, in require_version 
    raise ValueError('Namespace %s not available' % namespace) 
    ValueError: Namespace GstRtspServer not available 

1. Later I tried installing rtsp-server from source from the following repo 
:  https://gitlab.freedesktop.org/gstreamer/gst-rtsp-server.git

2. Compiling this gave me an error saying 'Gst-Rtsp.gir' files are missing 
from '/usr/share/gir-1.0'. To resolve this I copied the required '*.gir'  files to  '/usr/share/gir-1.0' from repo : 
https://github.com/sdroege/gstreamer-rs/blob/master/gir-files/GstRtsp-1.0.gir

3. make and make install was success. 

4. However, when importing this GstRtspServer in my application, I still have the issue : 
    ValueError: Namespace GstRtspServer not available 

5. I have seen a number of posts on this issue, and also tried different solutions suggested, however this still is not resolved. 

I am using Gstreamer 1.14.1

Does anyone have any pointers towards this issue ? 


Regards 

Labels (1)
Tags (2)
0 Kudos
3 Replies

3,056 Views
joanxie
NXP TechSupport
NXP TechSupport

what bsp version do you use? you can refer to the i.mx linux user guide, chapter 7.3.14 RTSP streaming server

0 Kudos

3,056 Views
imx_learner
Contributor I

Also, I am not using Yocto environment, but directly downloading the source and using make & make install. Could you provide me pointers as to where I am going wrong. 

0 Kudos

3,056 Views
imx_learner
Contributor I

How do I check the BSP version? I am using the Debian Stretch provided by Boundary Devices : Debian Stretch 9.2 for i.MX6/7 boards - October 2017 (kernel 4.1.15/4.9.x) - Boundary Devices 

0 Kudos