GPU performance issue in Linux 4.9.11 kernel on iMX6Q

cancel
Showing results for 
Search instead for 
Did you mean: 

GPU performance issue in Linux 4.9.11 kernel on iMX6Q

348 Views
balasubramaniya
Contributor II

Hi,

I am using Linux 4.9.11 with Yocto Morty build.

I am facing GPU performance issue in L4.9.11 kernel, when I'm running hellogles3 or any application from Qt5 examples the CPU loads nearly 30% but in L4.1.15 kernel with Yocto krogoth build CPU loads less than 2% only.

From the CPU utilization, we are considering L4.9.11 is using software decoder instead of hardware decoder.
Due to more CPU utilization in L4.9.11 Kernel, the device is increasing temperature rapidly.

Due to this QT examples runs slowly when compared to L4.1.15.

GPU Performance details:

L4.1.15 with KrogothL4.9.11 with Morty
CPU2%30%
MMDC GPU3DUtilization: 7%
Overall Bus Load: 35%
Bytes Access: 62
Utilization: 6%
Overall Bus Load: 34%
Bytes Access: 60
MMDC GPU2DUtilization: 1%
Overall Bus Load: 35%
Bytes Access: 63
Utilization: 1%
Overall Bus Load: 34%
Bytes Access: 63
MMDC SUMUtilization: 25%
Overall Bus Load: 36%
Bytes Access: 63
Utilization: 25%
Overall Bus Load: 35%
Bytes Access: 63

How to fix this issue or any patches available to solve the issue?

Hoping for a better guidance.


Best regards,
Bala

Labels (4)
0 Kudos
2 Replies

75 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi Bala,

Sorry, But I could not reproduced it, For me it appear that your QT samples are running on CPU.

0 Kudos

75 Views
balasubramaniya
Contributor II

Is it a known issue?

Best regards,
Bala

0 Kudos