Ethernet frequency not stable when boot up

cancel
Showing results for 
Search instead for 
Did you mean: 

Ethernet frequency not stable when boot up

73 Views
Contributor V

Hello,

I am working with IMX6D Android nougat build,  7.1.2 1.1.1-rc2-2.2. 

I have an issue on the Ethernet. 

During the startup of a board, the 50MHz reference PHY clock, which is generated by the Host processor and sent to the Ethernet PHY chip, turns on at the correct 50MHz for about 3 seconds, then becomes 125MHz (!?) for about 1 second, then turns off momentarily, then resumes at 50MHz.
I guess that the u-boot configures the Ethernet and wait for 3 seconds. It coincides the behavior of  the above clock freq changes. It seems like right after jumping to the kernel, the clock settings stays unknown state. 
We don't see the issue on the Jellybean Android build.
Have you guys seen this kind of issue ? any solution to this ?
Thanks and Regards,
Taehyuk Kwon
Labels (1)
0 Kudos
1 Reply

4 Views
NXP TechSupport
NXP TechSupport

Hi Taehyuk

one can try to rebuild all image from scratch, probably some previous

code changes were left. Also may be recommended to try more new release

Android N7.1.2_2.0.0 BSP Documentation

More NXP linux documentation can be found on

i.MX Software and Development Tools | NXP 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos