Error when flashing 8Mplus using UUU

cancel
Showing results for 
Search instead for 
Did you mean: 

Error when flashing 8Mplus using UUU

418 Views
junya
Contributor II

I'm trying to flash a i.MX 8Mplus(8MP) my custom board with the prebuilt linux images using Win10.

I run the command ;

./uuu -V -b emmc ./imx-boot-imx8mpevk-sd.bin-flash_evk

and get the following message;

uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.72-0-g8e9e189

Build in config:
Pctl Chip Vid Pid BcdVersion
==================================================
SDPS: MX8QXP 0x1fc9 0x012f [0x0002..0xffff]
SDPS: MX8QM 0x1fc9 0x0129 [0x0002..0xffff]
SDPS: MX8DXL 0x1fc9 0x0147
SDPS: MX28 0x15a2 0x004f
SDPS: MX815 0x1fc9 0x013e
SDPS: MX865 0x1fc9 0x0146
SDP: MX7D 0x15a2 0x0076
SDP: MX6Q 0x15a2 0x0054
SDP: MX6D 0x15a2 0x0061
SDP: MX6SL 0x15a2 0x0063
SDP: MX6SX 0x15a2 0x0071
SDP: MX6UL 0x15a2 0x007d
SDP: MX6ULL 0x15a2 0x0080
SDP: MX6SLL 0x1fc9 0x0128
SDP: MX7ULP 0x1fc9 0x0126
SDP: MXRT106X 0x1fc9 0x0135
SDP: MX8MM 0x1fc9 0x0134
SDP: MX8MQ 0x1fc9 0x012b
SDPU: SPL 0x0525 0xb4a4 [0x0000..0x04ff]
SDPV: SPL1 0x0525 0xb4a4 [0x0500..0x9998]
SDPU: SPL 0x0525 0xb4a4 [0x9999..0x9999]
SDPU: SPL 0x3016 0x1001 [0x0000..0x04ff]
SDPV: SPL1 0x3016 0x1001 [0x0500..0x9998]
FBK: 0x066f 0x9afe
FBK: 0x066f 0x9bff
FB: 0x0525 0xa4a5
FB: 0x18d1 0x0d02
FB: 0x3016 0x0001

Run built-in script:

uuu_version 1.2.39

# @./imx-boot-imx8mpevk-sd.bin-flash_evk | bootloader
# @./imx-boot-imx8mpevk-sd.bin-flash_evk [./imx-boot-imx8mpevk-sd.bin-flash_evk] | image burn to emmc, default is the same as bootloader

# This command will be run when i.MX6/7 i.MX8MM, i.MX8MQ
SDP: boot -f ./imx-boot-imx8mpevk-sd.bin-flash_evk

# This command will be run when ROM support stream mode
# i.MX8QXP, i.MX8QM
SDPS: boot -f ./imx-boot-imx8mpevk-sd.bin-flash_evk

# These commands will be run when use SPL and will be skipped if no spl
# SDPU will be deprecated. please use SDPV instead of SDPU
# {
SDPU: delay 1000
SDPU: write -f ./imx-boot-imx8mpevk-sd.bin-flash_evk -offset 0x57c00
SDPU: jump
# }

# These commands will be run when use SPL and will be skipped if no spl
# if (SPL support SDPV)
# {
SDPV: delay 1000
SDPV: write -f ./imx-boot-imx8mpevk-sd.bin-flash_evk -skipspl
SDPV: jump
# }

FB: ucmd setenv fastboot_dev mmc
FB: ucmd setenv mmcdev ${emmc_dev}
FB: ucmd mmc dev ${emmc_dev}
FB: flash bootloader ./imx-boot-imx8mpevk-sd.bin-flash_evk
FB: ucmd if env exists emmc_ack; then ; else setenv emmc_ack 0; fi;
FB: ucmd mmc partconf ${emmc_dev} ${emmc_ack} 1 0
FB: Done


Wait for Known USB Device Appear...
New USB Device Attached at 2:2
2:2>Start Cmd:SDPS: boot -f ./imx-boot-imx8mpevk-sd.bin-flash_evk
5%2:2>Fail HID(W):LIBUSB_ERROR_TIMEOUT(1.04s)

 

 

Do you have any idea what could cause this fail?

Tags (4)
0 Kudos
8 Replies

395 Views
junya
Contributor II

Hi, @khang_letruong  .

Thanks your reply.

 

>On Linux host machine (Ubuntu), one check if the board is in Serial Download mode with lsusb and runs the command with sudo : sudo ./uuu -V -b emmc ./imx-boot-imx8mpevk-sd.bin-flash_evk

 yes, we have verified the USB connection using the ISUSAB command and run the command;  

user@user-Lenovo-ideapad-100-15IBD:~/bin$ sudo ./uuu -V -b emmc ./imx-boot-imx8mpevk-sd.bin-flash_evk

>Not sure if we should open the console with administrator mode in Win10 ?

We open the console with administrator mode, but it's a Linux machine.

0 Kudos

385 Views
khang_letruong
Senior Contributor III

Hi,

As you are working with a custom board, it might be necessary to check the customized parts as in the following discussions :

https://community.nxp.com/t5/i-MX-Processors/UUU-not-working-to-flash-emmc-with-custom-i-mx-8m-nano/...

https://community.nxp.com/t5/i-MX-Processors/Setting-up-emmc-to-work-with-new-board/m-p/1385883

 

0 Kudos

382 Views
junya
Contributor II

Hi,

thanks your reply.

We try the content of the link below.

 

Please tell me one point.

For a custom board, do I need to change the uuu source code to match the board settings?

 

*modifications point from EVK to our custom board.

1. emmc

evk:SDINBDG4-32G-I1(sandisk)

custom:KLM4G1FETE-B041(samsung)

2.lpddr4

evk:MT53E1536M32D4DT-046 WT:A(micron)

custom:K4F8E3S4HD-MGCL(sumsung)

3.usb1(OTG)

evk:usb3.0, type-c

custom:usb2.0. micro b

4.debug serial(A53)

evk:uart2 (AF6,AH4)

custom:uart2(V29,V28)

 

 

0 Kudos

380 Views
khang_letruong
Senior Contributor III

Hi @junya ,

You would need to ensure that relevant drivers for custom parts (lpddr4, uart, usb which are crucial parts in u-Boot) are functional with traditional way of flashing into SD-card via dd'ing (i.e. those drivers are validated as functional with the custom image flashed into SD card) first.

K.

0 Kudos

366 Views
junya
Contributor II

hi, @khang_letruong 

Since the part to be customized is the content of the image, I don't think it has anything to do with the flashing failure, but is it different?

 

Or is the boot loader written once to the SOC's internal memory?

0 Kudos

360 Views
khang_letruong
Senior Contributor III
0 Kudos

338 Views
junya
Contributor II

Hi, @khang_letruong .

Thank you for your reply.

From the link you shared, I customized the settings such as USB.

As a result, the situation has improved, but it has stopped with problems related to emmc partition size.

How do I change the partition size of emmc?

 

yamamoto@ubuntu2004:~/bin$ sudo ./uuu -V -b emmc ~/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.72-0-g8e9e189

Build in config:
Pctl Chip Vid Pid BcdVersion
==================================================
SDPS: MX8QXP 0x1fc9 0x012f [0x0002..0xffff]
SDPS: MX8QM 0x1fc9 0x0129 [0x0002..0xffff]
SDPS: MX8DXL 0x1fc9 0x0147
SDPS: MX28 0x15a2 0x004f
SDPS: MX815 0x1fc9 0x013e
SDPS: MX865 0x1fc9 0x0146
SDP: MX7D 0x15a2 0x0076
SDP: MX6Q 0x15a2 0x0054
SDP: MX6D 0x15a2 0x0061
SDP: MX6SL 0x15a2 0x0063
SDP: MX6SX 0x15a2 0x0071
SDP: MX6UL 0x15a2 0x007d
SDP: MX6ULL 0x15a2 0x0080
SDP: MX6SLL 0x1fc9 0x0128
SDP: MX7ULP 0x1fc9 0x0126
SDP: MXRT106X 0x1fc9 0x0135
SDP: MX8MM 0x1fc9 0x0134
SDP: MX8MQ 0x1fc9 0x012b
SDPU: SPL 0x0525 0xb4a4 [0x0000..0x04ff]
SDPV: SPL1 0x0525 0xb4a4 [0x0500..0x9998]
SDPU: SPL 0x0525 0xb4a4 [0x9999..0x9999]
SDPU: SPL 0x3016 0x1001 [0x0000..0x04ff]
SDPV: SPL1 0x3016 0x1001 [0x0500..0x9998]
FBK: 0x066f 0x9afe
FBK: 0x066f 0x9bff
FB: 0x0525 0xa4a5
FB: 0x18d1 0x0d02
FB: 0x3016 0x0001

Run built-in script:

uuu_version 1.2.39

# @/home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk | bootloader
# @/home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk [/home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk] | image burn to emmc, default is the same as bootloader

# This command will be run when i.MX6/7 i.MX8MM, i.MX8MQ
SDP: boot -f /home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk

# This command will be run when ROM support stream mode
# i.MX8QXP, i.MX8QM
SDPS: boot -f /home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk

# These commands will be run when use SPL and will be skipped if no spl
# SDPU will be deprecated. please use SDPV instead of SDPU
# {
SDPU: delay 1000
SDPU: write -f /home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk -offset 0x57c00
SDPU: jump
# }

# These commands will be run when use SPL and will be skipped if no spl
# if (SPL support SDPV)
# {
SDPV: delay 1000
SDPV: write -f /home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk -skipspl
SDPV: jump
# }

FB: ucmd setenv fastboot_dev mmc
FB: ucmd setenv mmcdev ${emmc_dev}
FB: ucmd mmc dev ${emmc_dev}
FB: flash bootloader /home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk
FB: ucmd if env exists emmc_ack; then ; else setenv emmc_ack 0; fi;
FB: ucmd mmc partconf ${emmc_dev} ${emmc_ack} 1 0
FB: Done


Wait for Known USB Device Appear...
New USB Device Attached at 1:5
1:5>Start Cmd:SDPS: boot -f /home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk
100%1:5>Okay (2.526s)
libusb: error [udev_hotplug_event] ignoring udev action bind
New USB Device Attached at 1:5
1:5>Start Cmd:FB: ucmd setenv fastboot_dev mmc
1:5>Okay (0.016s)
1:5>Start Cmd:FB: ucmd setenv mmcdev ${emmc_dev}
1:5>Okay (0.098s)
1:5>Start Cmd:FB: ucmd mmc dev ${emmc_dev}
1:5>Okay (0.098s)
1:5>Start Cmd:FB: flash bootloader /home/yamamoto/imx-yocto-bsp/build/tmp/deploy/images/imx8mpevk/imx-boot-imx8mpevk-sd.bin-flash_evk
0x40000000Write partition failed1:5>Fail Write partition failed(0.25s)

 

0 Kudos

403 Views
khang_letruong
Senior Contributor III

Hi @junya ,

On Linux host machine (Ubuntu), one check if the board is in Serial Download mode with lsusb and runs the command with sudo : sudo ./uuu -V -b emmc ./imx-boot-imx8mpevk-sd.bin-flash_evk

Not sure if we should open the console with administrator mode in Win10 ?

Regards,
Khang

0 Kudos