ERROR: v4l2 capture: mxc_v4l_dqueue() interrupt received?

cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR: v4l2 capture: mxc_v4l_dqueue() interrupt received?

1,643 Views
gbiradar
Contributor IV

Hi Guys,

                As i'm working streaming application which uses hardware encryption(caam) with openssl. i'm able to stream for  <10 sec only after that i'm getting this error. i tried to find answer for this problem but of no use.

I'm working yocto setup with poky for i.MX6Q board which uses ov5640 mipi camera, streaming is done at fullhd(1920*1080).

[INFO]  Product Info: i.MX6Q/D/S

====== VPUENC: 4.0.3 build on Feb 17 2016 15:07:17. ======

wrapper: 1.0.58 (VPUWRAPPER_ARM_LINUX Build on Feb  9 2016 21:01:04)

vpulib: 5.4.28

firmware: 3.1.1.46063

Seekable................

[INFO]  ringBufferEnable 0, chromaInterleave 0, mapType 0, linear2TiledEnable 0

if any can help it will be useful.

regards,

Ganesh

0 Kudos
6 Replies

264 Views
joanxie
NXP TechSupport
NXP TechSupport

could you share the log file? what detailed ipu error message? is it timeout?  and what test did you use?

0 Kudos

264 Views
gbiradar
Contributor IV

Hi joanxie​,

i'm using gstreamer-1.0 pipeline.

gst-rtsp server 1.4.1 to test.

============================================================

14781267378462743823458945983245984356893459834562564839598345

46236458954890245249385

364726409439815974534-345234577345

[INFO]  Product Info: i.MX6Q/D/S

====== VPUENC: 4.0.3 build on Feb 17 2016 15:07:17. ======

wrapper: 1.0.58 (VPUWRAPPER_ARM_LINUX Build on Feb  9 2016 21:01:04)

vpulib: 5.4.28

firmware: 3.1.1.46063

Seekable................

[INFO]  ringBufferEnable 0, chromaInterleave 0, mapType 0, linear2TiledEnable 0

452385458845-345834578345734534938489573457

ERROR: v4l2 capture: mxc_v4l_dqueue() interrupt received

mxc_vpu 2040000.vpu: VPU interrupt received.

================================================================

that's it struck.

This is the maximum log i'm getting.

regards,

Ganesh

0 Kudos

264 Views
gbiradar
Contributor IV

Hi joanxie

this the dmesg log one more thing we increase the VPU frequency to 352M from earlier 266M in menuconfig and we getting the updated vpu log.

IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

ERROR: v4l2 capture: slave not found!

mxc_vpu 2040000.vpu: size=0x4000, page no.=0x2040

mxc_vpu 2040000.vpu: start=0x6dd6d000, pgoff=0x44d00, size=0x7c000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc size = 0x181000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc cpu_addr = 0xb6300000

mxc_vpu 2040000.vpu: start=0x6cbec000, pgoff=0x46300, size=0x181000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc size = 0x94000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc cpu_addr = 0xb6500000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc size = 0x2fd000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc cpu_addr = 0xb6600000

mxc_vpu 2040000.vpu: start=0x6953e000, pgoff=0x46600, size=0x2fd000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc size = 0x2fd000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc cpu_addr = 0xb6900000

mxc_vpu 2040000.vpu: start=0x69241000, pgoff=0x46900, size=0x2fd000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc size = 0x2fd000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc cpu_addr = 0xb6c00000

mxc_vpu 2040000.vpu: start=0x68f44000, pgoff=0x46c00, size=0x2fd000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc size = 0x2fd000

mxc_vpu 2040000.vpu: [ALLOC] mem alloc cpu_addr = 0xb6f00000

mxc_vpu 2040000.vpu: start=0x68c47000, pgoff=0x46f00, size=0x2fd000

ERROR: v4l2 capture: mxc_v4l_dqueue() interrupt received

mxc_vpu 2040000.vpu: [FREE] freed paddr=0x46F00000

mxc_vpu 2040000.vpu: [FREE] freed paddr=0x46C00000

mxc_vpu 2040000.vpu: [FREE] freed paddr=0x46900000

mxc_vpu 2040000.vpu: [FREE] freed paddr=0x46600000

mxc_vpu 2040000.vpu: [FREE] freed paddr=0x46500000

mxc_vpu 2040000.vpu: [FREE] freed paddr=0x46300000

0 Kudos

264 Views
joanxie
NXP TechSupport
NXP TechSupport

refer to the first error message, it seems you haven't download the camera module, you should confim if you have already installed the mipi camera or not.

0 Kudos

264 Views
gbiradar
Contributor IV

Camera will be in passive mode, once command is pass it will activate the camera module and streaming starts and after <10 seconds streaming stop.  then error.

dmesg: ERROR: v4l2 capture: mxc_v4l_dqueue() interrupt received -> camerasource:sr(current->comm ) : 698(current->pid) : 1(signal_pending(current)).

mxc_v4l2_capture.c

mxc_v4l_dqueue()

{

else if (signal_pending(current)) {

                pr_err("ERROR: v4l2 capture: mxc_v4l_dqueue() "

                        "interrupt received -> %s : %d : %d\n",current->comm, current->pid,signal_pending(current));

                return -ERESTARTSYS;

        }

}

0 Kudos

264 Views
gbiradar
Contributor IV

I have tried to check the signal which it is raising at streaming. when error popup the signal it is raising is 9 i.e sigkill i have no idea who is generating sigkill.

one question who can raised sigkill, user application or any kernel driver.

0 Kudos