ERROR: Function failed: Fetcher failure for URL: 'git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git'. Unable to fetch URL from any source.

cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR: Function failed: Fetcher failure for URL: 'git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git'. Unable to fetch URL from any source.

16,078 Views
wnm
Contributor I

Hi ,

  For  i.MX6 SABRE AI - BSP release L3.10.17_1.0.2_ga ,I get the below error when i follow the release notes



    ERROR: Function failed: Fetcher failure for URL: 'git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git'. Unable to fetch URL from any source.

    ERROR: Logfile of failure stored in: /home/wnm/freescale/7-April/fsl-release-bsp/build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/qt-in-industrial-embedded-smarthome/0.0+gitrAUTOINC+4b10cbfd32-   r3/temp/log.do_fetch.9853

  

     I see a answer from the community but that solutions points to a older version of the release  imx-3.10.17-1.0.0_ga   i.e  .Can someone clarify on this ?

Regards

wnm

Labels (1)
0 Kudos
8 Replies

1,545 Views
asick
Contributor III

Yocto linux for iMX6ULL porting: Error

~/fsl-arm-yocto-bsp/buildd$ bitbake core-image-minimal
NOTE: Your conf/bblayers.conf has been automatically updated.
WARNING: Host distribution "Ubuntu-18.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.
Parsing recipes: 100% |###################################################################################################################################################################| Time: 00:01:57
Parsing of 1663 .bb files complete (0 cached, 1663 parsed). 2197 targets, 184 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies

Build Configuration:
BB_VERSION = "1.30.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "Ubuntu-18.04"
TARGET_SYS = "arm-poky-linux-gnueabi"
MACHINE = "imx6ull14x14evk"
DISTRO = "poky"
DISTRO_VERSION = "2.1.1"
TUNE_FEATURES = "arm armv7ve vfp thumb neon callconvention-hard cortexa7"
TARGET_FPU = "hard"
meta
meta-poky = "HEAD:f5da2a5913319ad6ac2141438ba1aa17576326ab"
meta-oe
meta-multimedia = "HEAD:247b1267bbe95719cd4877d2d3cfbaf2a2f4865a"
meta-fsl-arm = "HEAD:be78894e4682f111575470fb23e51e6ba523508d"
meta-fsl-arm-extra = "HEAD:3dfb82fc7e703eae9891b3ffda0e9393701f2396"
meta-fsl-demos = "HEAD:a165068f8a0d1cf29aabe4b4053f28be1c2aa492"

NOTE: Fetching uninative binary shim from http://downloads.yoctoproject.org/releases/uninative/0.95/x86_64-nativesdk-libc.tar.bz2;sha256sum=26...
NOTE: Preparing RunQueue
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: gnu-config-native-20150728+gitAUTOINC+b576fa87c1-r0 do_unpack: Function failed: Fetcher failure: Fetch command failed with exit code 128, output:
fatal: the '--set-upstream' option is no longer supported. Please use '--track' or '--set-upstream-to' instead.

ERROR: Logfile of failure stored in: /home/fsl-arm-yocto-bsp/buildd/tmp/work/x86_64-linux/gnu-config-native/20150728+gitAUTOINC+b576fa87c1-r0/temp/log.do_unpack.5816
Log data follows:
| DEBUG: Executing python function do_unpack
| DEBUG: Executing python function base_do_unpack

| DEBUG: Python function base_do_unpack finished
| DEBUG: Python function do_unpack finished
| ERROR: Function failed: Fetcher failure: Fetch command failed with exit code 128, output:
| fatal: the '--set-upstream' option is no longer supported. Please use '--track' or '--set-upstream-to' instead.
|
ERROR: Task 299 (virtual:native:/home/fsl-arm-yocto-bsp/sources/poky/meta/recipes-devtools/gnu-config/gnu-config_git.bb, do_unpack) failed with exit code '1'
NOTE: Tasks Summary: Attempted 6 tasks of which 0 didn't need to be rerun and 1 failed.
Waiting for 0 running tasks to finish:

Summary: 1 task failed:
virtual:native:/home/fsl-arm-yocto-bsp/sources/poky/meta/recipes-devtools/gnu-config/gnu-config_git.bb, do_unpack
Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

0 Kudos

1,545 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello OtavioSalvador, would you know if this is a known issue?

ERROR: Task 299 (virtual:native:/home/fsl-arm-yocto-bsp/sources/poky/meta/recipes-devtools/gnu-config/gnu-config_git.bb, do_unpack) failed with exit code '1'

I've seen it repeatedly on the last few days.

Regards,

0 Kudos

1,545 Views
Yuri
NXP TechSupport
NXP TechSupport

Please try to use the recent BSP for the i.MX6, which may be found on the next Summary Page :

http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=IMX6_SW

http://www.freescale.com/webapp/Download?colCode=L3.10.53_1.1.0_iMX6QDLS_Bundle&appType=license&loca...

Have a great day,
Yuri

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

1,545 Views
wnm
Contributor I

Hi Yuri ,

the problem was solved by installing ...libsdl1.2-dev package on ubuntu 14.94 .for this .release-imx-3.10.53-1.1.0_ga

But the main query is still unsolved for this release --> imx-3.10.17-1.0.2_ga

Where i have to particularly carry out the test for this release ..and face the below error

ERROR: Function failed: Fetcher failure for URL: 'git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git'. Unable to fetch URL from any source.

Since i am intrested in this release imx-3.10.17-1.0.2_ga...Do we have a any workaround to fix the above error without upgrading to release-imx-3.10.53-1.1.0_ga?

regards

wnm

0 Kudos

1,545 Views
wnm
Contributor I

Hi,

    Was able to resolve the isuues by changing the url from github

1>

utils.git;protocol=git'. Unable to fetch URL from any source.

ERROR: Logfile of failure stored in: /home/wnm/freescale/yocto_3.10.17-1.0.2/build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/can-utils/1.0-r0/temp/log.do_fetch.26126

ERROR: Task 2878 (/home/wnm/freescale/yocto_3.10.17-1.0.2/sources/meta-fsl-bsp-release/imx/meta-fsl-demos/recipes-connectivity/can-utils/can-utils_1.0.bb, do_fetch) failed with exit code '1'

files affected

can-utils_1.0.bb


location

/sources/meta-fsl-bsp-release/imx/meta-fsl-demos/recipes-connectivity/can-utils/can-utils_1.0.bb


changed line

#SRC_URI = "git://git.gitorious.org/linux-can/can-utils.git;protocol=git"

SRC_URI = "git://github.com/linux-can/can-utils;protocol=https"

2>

ERROR: Fetcher failure: Fetch command failed with exit code 128, output:

Cloning into bare repository '/home/wnm/freescale/yocto_3.10.17-1.0.2/downloads//git2/gitorious.org.qt-in-use.qt-in-industrial-embedded.git'...

fatal: Could not read from remote repository.

Please make sure you have the correct access rights

and the repository exists.

ERROR: Function failed: Fetcher failure for URL: 'git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git'. Unable to fetch URL from any source.

Resolution : fix in recipe by changing the url

files affected

#qt-in-industrial-embedded-common.inc

location

#/sources/meta-fsl-demos/recipes-qt/qt-in-use

changed lines:

#SRC_URI = "git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git"

SRC_URI = "git://github.com/viaembedded/qt-in-industrial-embedded;protocol=https"

regards

wnm

0 Kudos

1,545 Views
wnm
Contributor I

I tried with the 1.1.0 (referring to the last 3 digits in release ) ...i end up with a different error...

wnm@os-lin-wnm:~/test-freescale/release-imx-3.10.53-1.1.0_ga$ MACHINE=imx6qsabreauto source fsl-setup-release.sh -b build -e x11 bitbake fsl-image-x11

Build directory is build

Using X11 backend with poky DIST_FEATURES

Welcome to Freescale Community BSP

The Yocto Project has extensive documentation about OE including a

reference manual which can be found at:

http://yoctoproject.org/documentation

For more information about OpenEmbedded see their website:

http://www.openembedded.org/

You can now run 'bitbake '

Common targets are:

core-image-minimal

meta-toolchain

meta-toolchain-sdk

adt-installer

meta-ide-support

Your configuration files at build have not been touched.

wnm@os-lin-wnm:~/test-freescale/release-imx-3.10.53-1.1.0_ga/build$ bitbake fsl-image-x11

ERROR: OE-core's config sanity checker detected a potential misconfiguration.

Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).

Following is the list of potential problems / advisories:

libsdl-native is set to be ASSUME_PROVIDED but sdl-config can't be found in PATH. Please either install it, or configure qemu not to require sdl.

ERROR: Execution of event handler 'check_sanity_eventhandler' failed

ERROR: Command execution failed: Exited with 1

Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

regards

wnm

0 Kudos

1,545 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello !

  Looks like environment was not set fully correctly.

Please follow section 3 (Host Setup) of "Freescale_Yocto_Project_User's_Guide.pdf"

exactly.

Regards,

Yuri.

0 Kudos

1,545 Views
wnm
Contributor I

Hi Yuri,

Thanks for the reply ,I dont know if you have seen my latest post ..I had the errors fixed...

Since its trying to fetch from a url and not finding one ..dont think so it was environment issue here..

Please see below for details ..Nevertheless can you give the link of the doc you mentioned ...

Regards

wnm

wasim muhammed Apr 13, 2015 1:50 AM (in response to wasim muhammed)

Hi,

Was able to resolve the isuues by changing the url from github

1>

utils.git;protocol=git'. Unable to fetch URL from any source.

ERROR: Logfile of failure stored in: /home/wnm/freescale/yocto_3.10.17-1.0.2/build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/can-utils/1.0-r0/temp/log.do_fetch.26126

ERROR: Task 2878 (/home/wnm/freescale/yocto_3.10.17-1.0.2/sources/meta-fsl-bsp-release/imx/meta-fsl-demos/recipes-connectivity/can-utils/can-utils_1.0.bb, do_fetch) failed with exit code '1'

files affected

can-utils_1.0.bb

location

/sources/meta-fsl-bsp-release/imx/meta-fsl-demos/recipes-connectivity/can-utils/can-utils_1.0.bb

changed line

#SRC_URI = "git://git.gitorious.org/linux-can/can-utils.git;protocol=git"

SRC_URI = "git://github.com/linux-can/can-utils;protocol=https"

2>

ERROR: Fetcher failure: Fetch command failed with exit code 128, output:

Cloning into bare repository '/home/wnm/freescale/yocto_3.10.17-1.0.2/downloads//git2/gitorious.org.qt-in-use.qt-in-industrial-embedded.git'...

fatal: Could not read from remote repository.

Please make sure you have the correct access rights

and the repository exists.

ERROR: Function failed: Fetcher failure for URL: 'git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git'. Unable to fetch URL from any source.

Resolution : fix in recipe by changing the url

files affected

#qt-in-industrial-embedded-common.inc

location

#/sources/meta-fsl-demos/recipes-qt/qt-in-use

changed lines:

#SRC_URI = "git://gitorious.org/qt-in-use/qt-in-industrial-embedded.git"

SRC_URI = "git://github.com/viaembedded/qt-in-industrial-embedded;protocol=https"

regards

0 Kudos