Downloading binary to SDCARD(SD4 Slot) using MfgTool on the MCIMX6SX-SDB board

cancel
Showing results for 
Search instead for 
Did you mean: 

Downloading binary to SDCARD(SD4 Slot) using MfgTool on the MCIMX6SX-SDB board

207 Views
Contributor III

Hi,

I'm using MfgTools in Windows 10.

The MfgTool_MultiPanel(Library: 2.7.0) was performed by executing the mfgtool2-yocto-mx-sabresd-sdcard-sd4.vbs of L4.9.88_2.0.0_mfg-tool.

MfgTool_MultiPanel.png

LOG : MfgTool_Initial.log

The SD4 slot on the MCIMX6SX-SDB board has an SDCARD loaded with binaries built with the yocto project (imx-4.9.88-2.0.0_ga/imx-linux-rocko).

The boot mode switch has been changed to Serial Download mode.

(BOOT_MODE0[D1] : ON / BOOT_MODE1[D2] : OFF))

Then, when boot up the board, Windows 10 installs the (Freescale SE Blank PELE) driver, but the MFG Tools are forced to terminate.

MfgTool_MultiPanel_Crash.png

LOG : MfgTool_Crash.log

Question. How can I download binaries to SDCard on the MCIMX6SX-SDB board using MfgTool?

Please answer.

Thanks.

Labels (2)
Tags (1)
0 Kudos
9 Replies

31 Views
NXP TechSupport
NXP TechSupport

refer to the user guide,  No dedicated boot DIP switches are reserved for serial download mode on i.MX 6 SABRE-SD and i.MX 6SoloLite boards, then when you connect your board with PC, check if you can find ""HID-compliant vendor-defined device" in the device manager, if you have issue for installing the driver, you need to check your PC, my win10 can install the driver successfully

pastedImage_1.png

pastedImage_2.png

0 Kudos

31 Views
Contributor III

Hi, Joan Xie.

Thank you for your answer.

I did the following, but I have a problem.

1. mode change

20200608_104115.jpg

2. Run the MFG_Tool

3. Power on the EVB board.

4. The MFG_Tool is terminated...

2~4. screen capture : http://shorturl.at/acmLP 

pastedImage_4.png

What are the differences causing this problem?

Please give me your opinion.
I appreciate it.

⨁ add contents : It works on other computers. it is the problem that only happens on my computer. In relation to that, is there anything wrong?

0 Kudos

31 Views
NXP TechSupport
NXP TechSupport

you don't need to change the boot mode as your picture shows, my board's setting is 1=OFF, 2=ON

0 Kudos

31 Views
Contributor III

Hi, Joan Xie.

I tested it under various conditions.

ComputerOSResult
DesktopWindows 10problem occurrence
NotebookWindows 7normal operation
VMWareWindows 10problem occurrence
VMWareWindows 7normal operation
VMWareWindows 8.1problem occurrence

As shown in the table above, it seems to be the problem in Windows 10 & 8.1.

Windows 7 works fine.
Can you confirm the status quo?

Please give me your opinion.
I appreciate it.

⨁ add contentsThere is also the forced shutdown problem in Linux.
The tested version is Ubuntu 12.04.3, 14.04.5, 16.04.6, 18.04 LTS.

Header 1
~/mfgtools$ sudo ./linux-runvbs.sh mfgtool2-yocto-mx-sabresd-sdcard-sd4.vbs
Your Options:
board: sabresd
mmc: 3
sxuboot: sabresd
sxdtb: sdb
Ready to flash.
Segmentation fault (core dumped)
~/mfgtools$
0 Kudos

31 Views
NXP TechSupport
NXP TechSupport

my laptop is  win10, everything is ok on my computer, did you check the driver installation successfully?

0 Kudos

31 Views
Contributor III

Hi, Joan Xie.

I got several windows 10 and tested them.

But it doesn't work.

Do you have a driver for Windows 10?


There is an event that failed migration in HID.

pastedImage_2.png

Please check again.

Thanks.

ps. The specification of my Windows 10 is "Windows 10 Pro / 1909 / 2020-02-24 / 18363.900"

pastedImage_3.png

⨁ add contents : The migration was resolved with the "sfc/scannow" command, but the MFGTool problem is not solved.

pastedImage_1.png

0 Kudos

31 Views
NXP TechSupport
NXP TechSupport

sorry for missing your reply how about the status now? any improvement?

0 Kudos

31 Views
Contributor III

Hi, Joan Xie.

MFGTools2 problem is not improved.

I think, it's a window 10 problem.

uuu is fine, so I'm using uuu instead of MFGTools2.

Thanks.

0 Kudos

31 Views
Contributor III

Hi, Joan Xie.

Thank you for your reply.
If it works on your Windows 10, I guess my Windows 10 is the problem.

I couldn't check it on another Windows 10 computer because nothing.

Thanks.

0 Kudos