Does Yocto Project require python, python2, or python3 ?

cancel
Showing results for 
Search instead for 
Did you mean: 

Does Yocto Project require python, python2, or python3 ?

404 Views
Contributor IV

From Yocto Project Quick Build,   'Python 3.4.0 or greater'

Yocto Project Quick Build 

Which Python is it referring to?  python, python2, or python3 ?

Tags (1)
5 Replies

52 Views
Senior Contributor II

Hi  Amer Naseem,

I have attached "Yocto project user's guide" which can be used to setup environment for imx yocto build. You can refer the packages which are required to build yocto from section 3.1 of attached user's guide.

Regards,

Radhika Somaiya.

52 Views
Contributor III

Hi all,

by the way, I have generated for Ubuntu Desktop 16 and currently trying 18, it seems that section 3.1 could be complemented with information;

For Ubuntu 16.04 and 18.04

apply "Essential Yocto Project host packages",

then "i.MX layers host packages for a Ubuntu 14.04",

and finally invoke "sudo apt-get  install curl"

For Ubuntu 18.04:

invoke also "sudo apt-get  install python"

Hope it helps

Laurent

52 Views
Contributor IV

"Yocto project  user's guide" directed me to "Yocto Project Quick Start" which requires to install Python 3.4.0 or greater.  Is version 3.4.0 for Phython or Python3 ?   I think it is Phython3 because version number starts with numeral 3 ?

package.PNG

versions.PNG

Regards,

Amer

0 Kudos

52 Views
Contributor III

python (short name for python2) is also required.

best regards

52 Views
NXP TechSupport
NXP TechSupport

Hello,

Python3, refers to python 3.4.0 or more as its update by Ubuntu.

Regards