Configure Interrupt mode for Ethernet

cancel
Showing results for 
Search instead for 
Did you mean: 

Configure Interrupt mode for Ethernet

277 Views
a_thomas
Contributor II

Hi There,

I am running on imx8 and on linux imx branch 5.4.24_2.3.0

I am not able to change the polling mode of the ethernet driver.

In dp83811_driver , i tried changing the variable "flags" in the phy_driver structure to PHY_HAS_INTERRUPT. But after booting i still get this message in kernel log.

attached PHY driver [TI DP83TC811] (mii_bus:phy_addr=5b040000.ethernet-1:00, irq=POLL)

Should this be done in Uboot or in kernel driver?

can anyone point me to a right direction on how to do this?

 

0 Kudos
2 Replies

249 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi a_thomas

 

if DP83TC811 "INT" output signal is connected to i.MX gpio, one can look at example for
i.MX6Q where GPIO6 is selected to service ENET interrupts :

https://source.codeaurora.org/external/imx/linux-imx/tree/arch/arm/boot/dts/imx6q-arm2.dts?h=imx_5.4...

&fec {
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_enet>;
phy-mode = "rgmii";
interrupts-extended = <&gpio1 6 IRQ_TYPE_LEVEL_HIGH>,

 

Best regards
igor

233 Views
a_thomas
Contributor II

Hello Igor,

 

Thanks for the quick reply, yes a similar approach seems to work. But, i don't understand a few things completely. 

1. why a new interrupt number is given by Linux (cat /proc/interrupts).  Is there another mechanism where Linux internally calculates an interrupt number?

2. The Link seems to be Up, but Speed and Duplex setting seems to be Unknown for some reason. all i changed was the entry in DTS and the PHY_HAS_INTERRUPT flag in driver.

 

Best Regards

Thomas

0 Kudos