Can't compile Qt5 application on IMX8MQEVK

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't compile Qt5 application on IMX8MQEVK

100 Views
Contributor I

Hi, 

I am trying to compile an application in imx8mqevk kit. I have used the fsl-image-qt5-validation-imx image to build yocto project. I am able to run a compiled application from /usr/share/qt5/examples folder. But when I compile a QT application, it's missing qt5 libraries. I can't find QtCore, QtWidgets in /usr/include folder or anywhere in root for that matter. Is there anything wrong in my yocto build ? Any insights on step by step procedure to build/install tools for qt5 build is very helpful.

Thanks.

Harsha

Tags (2)
0 Kudos
1 Reply

5 Views
NXP TechSupport
NXP TechSupport

Hi Harsha

one can look at Qt forums

How to Cross-compile Qt App for I.MX8MQEVK(fsl-image-qt5-validation-imx) | Qt Forum 

How to Cross Compile to IMX8M? | Qt Forum 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos