About IMX8MQ USB camera issue

cancel
Showing results for 
Search instead for 
Did you mean: 

About IMX8MQ USB camera issue

294 Views
Contributor III

Hi NXP teams:

  I've had a problem recently.

 When I flash NXP offical demo image(Android P9_0.0_1.0.0)  into evk board,I found in system dev directory.

It already exists /dev/video0 /dev/video1,When I plugged in a USB camera,the sensor will be registered from video2.

Is there any way to remove the /dev/video0 and /dev/video1?   In addition, I found that the video0 and video1 are registered by the following code.

fsl-imx8mq-evk.dts

&csi1_bridge {
fsl,mipi-mode;
fsl,two-8bit-sensor-mode;
status = "okay";

port {
csi1_ep: endpoint {
remote-endpoint = <&csi1_mipi_ep>;
                             };
       };
};

&csi2_bridge {
fsl,mipi-mode;
fsl,two-8bit-sensor-mode;
status = "okay";

port {
csi2_ep: endpoint {
remote-endpoint = <&csi2_mipi_ep>;
                             };
        };
};

fsl-imx8mq.dtsi

csi1_bridge: csi1_bridge@30a90000 {
compatible = "fsl,imx8mq-csi", "fsl,imx6s-csi";
reg = <0x0 0x30a90000 0x0 0x10000>;
interrupts = <GIC_SPI 42 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clk IMX8MQ_CLK_DUMMY>,
<&clk IMX8MQ_CLK_CSI1_ROOT>,
<&clk IMX8MQ_CLK_DUMMY>;
clock-names = "disp-axi", "csi_mclk", "disp_dcic";
status = "disabled";
};

csi2_bridge: csi2_bridge@30b80000 {
compatible = "fsl,imx8mq-csi", "fsl,imx6s-csi";
reg = <0x0 0x30b80000 0x0 0x10000>;
interrupts = <GIC_SPI 43 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clk IMX8MQ_CLK_DUMMY>,
<&clk IMX8MQ_CLK_CSI2_ROOT>,
<&clk IMX8MQ_CLK_DUMMY>;
clock-names = "disp-axi", "csi_mclk", "disp_dcic";
status = "disabled";
};

I'm not sure if I can delete the registration of this node.

thanks

Tags (1)
0 Kudos
2 Replies

9 Views
NXP TechSupport
NXP TechSupport

Hi yingjin

seems /dev/video0 and /dev/video1 are related to mipi-csi interfaces described in

sect.6.1.4 MIPI Camera Serial Interface (MIPI CSI) attached Linux Manual,

one can try to disable them setting status = "disabled".

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

9 Views
Contributor III

Hi  igor

my change as below :

&csi1_bridge {
        fsl,mipi-mode;
        fsl,two-8bit-sensor-mode;
        status = "disabled";   --->from okay to disabled

        port {
          csi1_ep: endpoint {
           remote-endpoint = <&csi1_mipi_ep>;
    };
  };
};

&csi2_bridge {
        fsl,mipi-mode;
        fsl,two-8bit-sensor-mode;
        status = "disabled";   --->from okay to disabled

        port {
           csi2_ep: endpoint {
           remote-endpoint = <&csi2_mipi_ep>;
    };
  };
};

After the change,the dev file folder is not exist /dev/video0 and /dev/video1 ,When I plug in USB camera,the system will be registerd the video0 file node.But when I use system camera app open the camera,the system crashed.

The log is attached.Could you help me  check it ?

BRs

thanks

0 Kudos