All Boards Creating App MP3

Showing results for 
Search instead for 
Did you mean: 

All Boards Creating App MP3

No ratings

All Boards Creating App MP3

First execute LTIB (./ltib -c) and select these packages: all gstreamer plugin, alsa-utils and libmad.

Create your file code (i.e.: playmp3.c):

#include <gst/gst.h>

#include <glib.h>

static gboolean
  bus_call (GstBus    *bus,
            GstMessage *msg,
            gpointer    data)
  GMainLoop *loop = (GMainLoop *) data;

  switch (GST_MESSAGE_TYPE (msg)) {

          case GST_MESSAGE_EOS:
              g_print ("End of stream\n");
              g_main_loop_quit (loop);

          case GST_MESSAGE_ERROR: {
              gchar  *debug;
              GError *error;

              gst_message_parse_error (msg, &error, &debug);
              g_free (debug);

              g_printerr ("Error: %s\n", error->message);
              g_error_free (error);

              g_main_loop_quit (loop);

    return TRUE;

main (int  argc,
              char *argv[])
      GMainLoop *loop;

      GstElement *pipeline, *source, *decoder, *conv, *resample, *sink;
      GstBus *bus;

      /* Initialisation */
      gst_init (&argc, &argv);

      loop = g_main_loop_new (NULL, FALSE);

      /* Check input arguments */
      if (argc != 2) {
          g_printerr ("Usage: %s <MP3 filename>\n", argv[0]);
          return -1;

        /* Create gstreamer elements */
      pipeline = gst_pipeline_new ("audio-player");
      source  = gst_element_factory_make ("filesrc",      "file-source");
      decoder  = gst_element_factory_make ("mad",      "mp3-decoder");
      conv    = gst_element_factory_make ("audioconvert",  "converter");
      resample = gst_element_factory_make ("audioresample", "audio-resample");
      sink    = gst_element_factory_make ("autoaudiosink", "audio-output");

      if (!pipeline || !source || !decoder || !conv || !resample || !sink) {
          g_printerr ("One element could not be created. Exiting.\n");
          return -1;

      /* Set up the pipeline */

      /* we set the input filename to the source element */
      g_object_set (G_OBJECT (source), "location", argv[1], NULL);

        /* we add a message handler */
        bus = gst_pipeline_get_bus (GST_PIPELINE (pipeline));
        gst_bus_add_watch (bus, bus_call, loop);
        gst_object_unref (bus);

        /* we add all elements into the pipeline */
        /* file-source | mp3-decoder | converter | resample | alsa-output */
        gst_bin_add_many (GST_BIN (pipeline),
                                                      source, decoder, conv, resample, sink, NULL);

          /* we link the elements together */
          /* file-source -> mp3-decoder -> converter -> resample -> alsa-output */
          gst_element_link_many (source, decoder, conv, sink, NULL);

        /* Set the pipeline to "playing" state*/
        g_print ("Now playing: %s\n", argv[1]);
        gst_element_set_state (pipeline, GST_STATE_PLAYING);

        /* Iterate */
      g_print ("Running...\n");
      g_main_loop_run (loop);

        /* Out of the main loop, clean up nicely */
        g_print ("Returned, stopping playback\n");
      gst_element_set_state (pipeline, GST_STATE_NULL);
      g_print ("Deleting pipeline\n");
      gst_object_unref (GST_OBJECT (pipeline));

          return 0;


Create a directory inside your ltib directory to compile your source code:

$ mkdir ~/your-ltib-dir/rpm/BUILD/gst

Enter on LTIB shell mode:

$ ./ltib -m shell

Entering ltib shell mode, type 'exit' to quit


Enter in your application dir:

LTIB> cd rpm/BUILD/gst/

Compile your application:

LTIB> gcc -Wall $(pkg-config --cflags --libs gstreamer-0.10) playmp3.c -o playmp3

If everything worked file you will get a "playmp3" arm binary:

LTIB> file playmp3
playmp3: ELF 32-bit LSB executable, ARM, version 1 (SYSV), for GNU/Linux 2.6.14, dynamically linked (uses shared libs), not stripped

Now just copy it to ~/your-ltib-dir/rootfs/home.

Start your board using this rootfs and execute:

root@freescale ~$ cd /home/
root@freescale /home$ ./playmp3 your-file.mp3
Now playing: your-file.mp3

Tags (1)

I have tried to compile this application for i.MX6Q and it's compiling but not running properly.

When I run the application I get the following message and there is no output on the display:

/playvideo clipcanvas_14348_offline.mp4

this is powerful mx6q

MFW_GST_V4LSINK_PLUGIN 3.0.1 build on Nov 30 2012 15:01:54.

(playvideo:2088): GLib-GObject-WARNING **: g_object_set_valist: object class `GstVpuDec' has no property named `codec-type'

Now playing: clipcanvas_14348_offline.mp4

[INFO] Product Info: i.MX6Q/D/S

vpudec versions :smileyhappy:

  plugin: 3.0.1

  wrapper: 1.0.24(VPUWRAPPER_ARM_LINUX Build on Nov 30 2012 14:55:19)

  vpulib: 5.4.6



Can you please suggest the changes needed for i.MX6Q ?

Please not the command line is working fine:

gst-launch filesrc location=big_buck_bunny.mp4 typefind=true ! aiurdemux ! vpudec ! mfw_v4lsink

Works !

Version history
Revision #:
1 of 1
Last update:
‎08-06-2012 09:41 AM
Updated by: