MQX OpenVG 0.5.0 disabling fbws

cancel
Showing results for 
Search instead for 
Did you mean: 

MQX OpenVG 0.5.0 disabling fbws

384 Views
NXP Employee
NXP Employee

Hello,

 

To disable 0.5.0 and keep compatiblity with EGL Pbuffers I did the following:

 

- patched hal/os/mqx/user/gc_hal_user_fbws.c to disable fbws

- built all four required libraries:

     - check section 3.2 from vf600_ovg\doc\OpenVG Driver on MQX User's Guide.pdf

 

- copy the rotation application "rotation" folder from a 0.4.0 distribution to test/

- renamed folder to rotation.0.4

- patched tests/rotation.0.4/ovgmain.c

- copy build-autovf600-gnu-mqx-d folder from rotation folder to rotation.0.4

- modified tests\rotation.0.4\ovgapp.h so WIDTH and HEIGH #if to 800x600

- cd tests\rotation.0.4\build-autovf600-gnu-mqx-d\eclipse make MQX_TWRVF65GS10_PATH=$MQX_ROOT

 

You should see the rotating tiger if you are using DVI connector.

 

Maybe this will be helpful for you Jim Mikola

Original Attachment has been moved to: 0001-Disable-FBWS-to-be-compatible-with-0.4.0.patch.zip

Original Attachment has been moved to: 0002-0.4.0-application-porting-example.patch.zip

Labels (1)
Tags (3)
0 Kudos
2 Replies

11 Views
Contributor I

It would be good to patch eglfsl.h to eliminate the warning when using this build configuration:

#ifdef ENABLE_FBWS

#warning "This function is obsolete, don't make use of it any longer"

#endif

0 Kudos

11 Views
Contributor I

I have this working with OVG 0.5.0 and BSP 4.0.2-ALPHA2.  So far it runs great.

0 Kudos