using apex core with vsdk 0.96

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

using apex core with vsdk 0.96

1,636 Views
imarkwang
Contributor I

I tried to draw some apex graph in the eclipse,  When I validate the graph, it will complains:

"
An exception occurred while delegating evaluation of the 'atLeastOneInput' constraint on 'APEX_MetaProcessClass::APEX_GraphClass': java.lang.IllegalStateException: No 'http://www.eclipse.org/emf/2002/Ecore/OCL/Pivot' ValidationDelegate for 'APEX_MetaProcessClass::APEX_GraphClass' default.apex_metagraph /apex_096_test Unknown EMF Problem


An exception occurred while delegating evaluation of the 'atLeastOneKernel' constraint on 'APEX_MetaProcessClass::APEX_GraphClass': java.lang.IllegalStateException: No 'http://www.eclipse.org/emf/2002/Ecore/OCL/Pivot' ValidationDelegate for 'APEX_MetaProcessClass::APEX_GraphClass' default.apex_metagraph /apex_096_test Unknown EMF Problem

An exception occurred while delegating evaluation of the 'atLeastOneOutput' constraint on 'APEX_MetaProcessClass::APEX_GraphClass': java.lang.IllegalStateException: No 'http://www.eclipse.org/emf/2002/Ecore/OCL/Pivot' ValidationDelegate for 'APEX_MetaProcessClass::APEX_GraphClass' default.apex_metagraph /apex_096_test Unknown EMF Problem

Tags (2)
0 Kudos
Reply
5 Replies

1,323 Views
jiri_kral
NXP Employee
NXP Employee

Hello, 

What is your 32DS for Vision version? The vsdk EAR v0.9.6 is old one (2016-10-28). Please update to current vsdk RTM v1.0.0. If you have older S32DS for vision (current version is 2.0) - please get the latest version here:

S32 Design Studio for Vision Processors|NXP 

Jiri

0 Kudos
Reply

1,323 Views
imarkwang
Contributor I

hi,Jiri.

Our apps using ISP are running on the vsdk 0.96 version now. It may need some work to move our apps from vsdk 0.96 to vsdk 1.0. And we didn't use apex on vsdk 0.96 yet, so decided to startup apex based on vsdk 0.96 firstly.

The enviroment I had builded according to the file "C:\NXP\VGS_S32V2xx_EAR_0_9_6_9989b9\apex\APEX_VGS_Installation_Readme.pdf".

1.eclipse-epsilon-1.4-win32-x86_64

2.VGS_S32V2xx_EAR_0_9_6_*

3.VisionSDK_S32V2xx_EAR_0_9_6_*

So I wanna to confirm that:

1.Is the envirment enough for developing apex core? What should I do to fix this problem?

2.Do you have anohter method(developing enviroment) to using apex core based on vsdk 0.96?

0 Kudos
Reply

1,323 Views
jiri_kral
NXP Employee
NXP Employee

Hi Mark,

Well - there is lot of changes between EAR 0.9.6 and RTM 1.0.0. From my point of view - it is wasting time trying finish project under Early Access Release (without any support). The Apex is working in 0.9.6 - but there are bugs.  

Better idea is migrate your existing ISP project into vsdk 1.0.0 and continue with Apex development in this SDK.

You can try the S32DS for Vision - there is integrated RTM vsdk 1.0.0 and S32DS is based on Eclipse Neon. In S32DS  are included examples for Apex/ISP. It is possible that you can re-use  some part in your project. 

Jiri 

0 Kudos
Reply

1,323 Views
imarkwang
Contributor I

okay. Thanks. Jiri. 

But do you have any solutions for this problem?

0 Kudos
Reply

1,323 Views
jiri_kral
NXP Employee
NXP Employee

Sorry, but I have no solution for your issue. It looks like that it is eclipse-related. I'll re-send your issue to Vision team - hope they can help you. 

Jiri 

0 Kudos
Reply