why s32k116 partion RAM will reset without in debug mode

cancel
Showing results for 
Search instead for 
Did you mean: 

why s32k116 partion RAM will reset without in debug mode

410 Views
Contributor IV

Hello

       Just as the saying goes, it is always difficult to understand new things.Now ,l meet a problem difficult to solve.

       When l want partion S32K116 RAM ,l find in debug mode, the program is narmal.But without in debug mode,the program run is not naomal and the s32k116 chip reset always.

        l have use the s32k144 and s32k146 two years,l did not meet this problem .

        I think maybe scrip file"S32K1xx_flash.ld" what l setted is wrong.but l  do not know which wrong .l have submitted the problem several days ago,but it did not resolved.the link isHOW to partition S32K116 RAM 

       Now, I  will  instruction the problem detailed .

        In debug mode, l  initialize RAM1  area  variable ,the project run sucess.In not debug mode,when the project run to set RAM1 area variable (  RAM1_TEST1=1;), the chip will reset. just as bellow:

pastedImage_308.png

 

     l think the question is l have setted "S32K1xx_flash.ld" file wrong.please tell how to set "S32K1xx_flash.ld".

the memory setting as follow.

pastedImage_124.png

 

pastedImage_3.png

 

in project ,I add define as bellow

#define SRAM1_STRORG __attribute__ ((section(".SRAM1"))) /* 8k */

 

#define SRAM1_STRORG_UINT8 SRAM1_STRORG uint8_t
#define SRAM1_STRORGL_UINT16 SRAM1_STRORG uint16_t
#define SRAM1_STRORGL_INT16 SRAM1_STRORG int16_t
#define SRAM1_STRORG_UINT32 SRAM1_STRORG uint32_t

 

l have upload the project ,please reselve my questing,thank you.

Tags (2)
0 Kudos
7 Replies

148 Views
Contributor III

Hello jinshuai xu,

   I have worked on S32K144,148 but not on 116. Still can you please share the generated map file?.


Also the 144 or 148 example from the design studio has the flash partitioning example. Can you please try to use those functions in your project?.

0 Kudos

148 Views
Contributor IV

Hi

s32k116 script file is in the project and the project l have uploaded.s32k142 146 148 chip l have use two years and l partion ram is normal.So l think you can test the Project in s32k116 chip if you have the s32k116 Demo board .you will know what l said problem.

-Original-

0 Kudos

148 Views
NXP Employee
NXP Employee

Hi jinshuai xu

I have tested your code in my side and I can't see any problem with it, could you clarify what issue are you seeing?

pastedImage_1.png

Also, as Jiri recommend you, It would be better for you if you use the Emulated EEPROM for your application, so please consider this option too.

Hope this information helps.
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!
-------------------------------------------------------------------------------

0 Kudos

148 Views
Contributor IV

Hi

     the problem l raise: s32k116 partion RAM will reset without in debug mode.  

     So if you test the project in debug mode ,the project is normal.you can test it in not debug mode.

0 Kudos

148 Views
NXP Employee
NXP Employee

Hi jinshuai xu

Could you clarify what you mean with debug mode? I can run the code and then if I attached to the MCU (without the active debug session), I can corroborate that your code works normally.

Regards

Jorge Alcala

0 Kudos

148 Views
Contributor IV

 In debug mode:use MULTILINK online simulation. 

without in debug mode: upload programe to s32k116 chip.power on  the chip again.

0 Kudos

148 Views
NXP Employee
NXP Employee

Hi jinshuai xu

I loaded your project to the S32K116 EVB, power on the board and then with an attach I can corroborate that your projects work normally. Could you clarify what issue are you seeing and how are you checking the data in the RAM memory?

Regards

0 Kudos