[S32K144EVB] Flash programming error occurring

cancel
Showing results for 
Search instead for 
Did you mean: 

[S32K144EVB] Flash programming error occurring

1,501 Views
youngsamkim
Contributor I

Dear all,

I got a problem about the flash programming.

I made a test project referred from a FLASH_Example of EAR SDK 0.8.2 and then I  executed debug mode on step by step procedure to verify an operation I expected.

After finishing debugging, an error message is displayed whenever I download new .elf to the EVB.

I think that I made a mistake when I use a flash command for partition or program with secure key...

you can refer to below error message I saw. please let me know how can I solve this problem.

===Error Message===

CMD>VC
Verifying object file CRC-16 to device ranges ...
block 00000000-0000610F ...

Error! CRC Command Timed Out
CMD>EM
Command is inactive for this .ARP file.
Error Erasing flash of device
Error occured during Flash programming.

Thanks

BR Young.

Labels (1)
Tags (2)
5 Replies

556 Views
raresvasile
NXP Employee
NXP Employee

Hi Young,

This is a know issue of the Flash example and it will secure the device.

To make the board usable you need to perform a mass erase of the chip. Open the PEMicro debug configuration and select "Emergency Kinetis Recovery using mass erase" in Debugger tab. This will perform the required mass erase and will make the board flashable again.

pastedImage_1.png

Best regards,

Rares

556 Views
ray_deng1
Contributor III

Hi Rares,

This method is working for re-program, and if for Bootloader , how to fix the issue, when update application successful 1st time and found update failure for the rest time?

BRs,

Ray

306 Views
AnsBet
Contributor I

Hi ray_deng1! 

Do you have solved this issue? I am in the same situation. I am using the bootloader described in AN12218. When I send via UART and load for the first time the application then it works, but when I send via UART the new updated application then it does not work. I verified that the program counter is always correctly inizialized with the adress of the application to run.

How can I solve this issue?

Thank you to who can help me.

AnsBet

0 Kudos

556 Views
alexandrehochar
Contributor III

Hi Rares,

I have the same problem after an unlucky erase block command in my code.
The chip can't be programmed or erased.
Check the emergency option doesn't work.
I don't know how an erase command can stuck the chip.
Indeed, 0b11 on FSEC->SEC protect the chip but 0b11 on FSEC->MEEN enable the mass erase.

Because mistakes never happen alone, i stuck two boards like this. I need help!

Regards,

0 Kudos

556 Views
youngsamkim
Contributor I

Dear Rares,

Thanks for your support. The problem has been solved by your advice.

BR,

Young.

0 Kudos