S32K144-EVB Cannot flash/debug. Device is secure.

cancel
Showing results for 
Search instead for 
Did you mean: 

S32K144-EVB Cannot flash/debug. Device is secure.

2,255 Views
smartgoat
Contributor I

Dear all,

I am working on some examples related to CSECs of the S32K144-EVB. Accidentally, I cannot flash or debug the program using S32DS v1.3. It said that "Device is secure. Erase to unsecure?". I select "Yes" and let the IDE erases the board. But it cannot.

When I plug the board to power source (usb or external adapter), the red led next to reset button is always ON.

When I try to connect to the board using pegdbserver_console, the application "Cannot enter background mode"

I was able to enter bootloader mode of OpenSDA. I am sure that there is no physical connection problem.

Is there any solution to get the board working? What is the cause of this issue?

Thanks all.

Tags (2)
0 Kudos
3 Replies

409 Views
danielmartynek
NXP TechSupport
NXP TechSupport

Hi,

Did you try the Emergency Kinetis Device Recovery option?

Emergency_kinetis_device_recovery.png

Regards,

Daniel

0 Kudos

409 Views
smartgoat
Contributor I

Hi Daniel,

Thanks so much for your reply. I already tried that, but no success.

I tried to investigate the issue using j-link. I found that the board is "secure" and "mass erase" is enabled. So theoretically, it can be erased to unsecure. But in practice, it does not.

I also tried to flash the binary or read memory (SRAM) using j-link. But j-link keeps reporting error:

"Protection bytes in flash at addr. 0x400 - 0x40F indicate that readout protection is set and mass erase is disabled."

"Timeout while halting CPU"

When I execute "unlock kinetis", j-link reports OK. But the above error persists when I try other commands.

Is my board "bricked"? Is there any solution to recover it?

With Regards,

0 Kudos

409 Views
danielmartynek
NXP TechSupport
NXP TechSupport

Hi,

What did you actually load to the chip?

Have you read this thread and this document?

Although it is Kinetis, it should be similar.

But if the mass erase is really disabled (MEEN = 0b10), then it is probably bricked.

Regards,

Daniel

0 Kudos