S32K116 J-LINK Debug

cancel
Showing results for 
Search instead for 
Did you mean: 

S32K116 J-LINK Debug

803 Views
Vincent612
Contributor I

Hi,

I am currently trying to flash a S32DS Application Project to my S32K116 MCU through J-Link.

The issue that I am having is that everytime I launch the flash sequence, I get the same error message.

Here is the Console Output:

SEGGER J-Link GDB Server V6.42a Command Line Version

JLinkARM.dll V6.42a (DLL compiled Feb 1 2019 18:00:08)

Command line: -if swd -device S32K116 -endian little -speed 1000 -port 2331 -swoport 2332 -telnetport 2333 -vd -ir -localhostonly 1 -singlerun -strict -timeout 0 -nogui
-----GDB Server start settings-----
GDBInit file: none
GDB Server Listening port: 2331
SWO raw output listening port: 2332
Terminal I/O port: 2333
Accept remote connection: localhost only
Generate logfile: off
Verify download: on
Init regs on start: on
Silent mode: off
Single run mode: on
Target connection timeout: 0 ms
------J-Link related settings------
J-Link Host interface: USB
J-Link script: none
J-Link settings file: none
------Target related settings------
Target device: S32K116
Target interface: SWD
Target interface speed: 1000kHz
Target endian: little

Connecting to J-Link...
J-Link is connected.
Firmware: J-Link ARM-OB STM32 compiled Aug 22 2012 19:52:04
Hardware: V7.00
S/N: 20090928
Feature(s): RDI,FlashDL,FlashBP,JFlash,GDB
Checking target voltage...
Target voltage: 3.30 V
Listening on TCP/IP port 2331
Connecting to target...WARNING: CPU could not be halted
WARNING: CPU could not be halted
WARNING: CPU could not be halted
WARNING: CPU could not be halted
WARNING: CPU could not be halted
WARNING: CPU could not be halted
Halting target device failed. Trying again with reset
WARNING: CPU could not be halted
WARNING: CPU could not be halted
WARNING: CPU could not be halted
WARNING: CPU could not be halted
WARNING: CPU could not be halted
Failed to halt target device on connect
ERROR: Could not connect to target.
Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...
Shutting down...

Does anyone know what is the cause of this issue?

0 Kudos
3 Replies

792 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi Vincent612,

I am not quite sure if it was caused by your debugger. It shows: Firmware: J-Link ARM-OB STM32 compiled Aug 22 2012 19:52:04
Maybe this firmware is only to be used with ST target devices.
Have you try to use other firmware?

Do you have other external debugger?

 

Best Regards,
Robin

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

788 Views
Vincent612
Contributor I

Hi Robin,

I only have this J-Link debugger. When I bought this debugger, it mentions that it is able to support STM and NXP microcontroller.

Unfortunately I don't have another debugger to test the flashing. Is there any other alternatives?

 

0 Kudos

772 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Would you please show me the website of this debugger?

Here is the SEGGER J-Link OB, you can find there are several J-Link OB models. 

I am not sure if it was caused by this:

Licensing options.png

 

Best Regards,
Robin

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos