the ethernet example

cancel
Showing results for 
Search instead for 
Did you mean: 

the ethernet example

705 Views
961271210
Contributor I

I try to debug the lwip example for many times. But it always tells me that there are different errors. When I get the example project, I change the include route as follows. 

pastedImage_1.png

If I add the last path into the route, the S32 say it cannot detect my device when I debug.

pastedImage_2.png

if I do not add the last path, the S32 says it cannot find lots of files.

pastedImage_3.png

I do not know why and I just change the route. I wonder if I should change any other settings to debug it or do something. I really have no ideas to solve it. Anyone have some good solution to solve it ?

thanks

Jupeng

0 Kudos
7 Replies

298 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

I tried your project. With EWL nano it can't be built. I replaced EWL nano with standard EWL library and there is no issue with build:

pastedImage_1.png

What is your EVB? 

Jiri

0 Kudos

298 Views
961271210
Contributor I

Hi,

After I changed the library, I try to debug it, the device cannot be detected, either. If I use SDApoat to debug, the project cannot give me any correct reaction when I send message to the board. Are there any other solutions? 

thnaks,

Jupeng

0 Kudos

298 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

by EVB I mean which type of evaluation board do you have. But it looks that you have the arduino-like one with integrated OpenSDA PE Micro debugger. 

In your project are two issues. First one - project can't be compiled if EWL Nano C Library is used. This can be fixed if you switch C library to EWL. 

Second "issue" is - you have OpenSDA debugger on your board and you are trying use PE Micro Multilink FX probe - which is standalone hardware probe from PE Micro - Multilink FX | Advanced High Performance Debug Probe | PEmicro  . OpenSDA Embedded debug is right choice in debug configurations. 

What do you mean by - cannot give me any correct reaction when I send message to Board? I'm not familiar with this example (looks that it is from ST), but it looks that this example should respond when UDP packet is received. Do you have correct network settings and so on? 

Jiri

0 Kudos

298 Views
961271210
Contributor I

Hi,

For the EVB, I use MPC5748g as my board. Changing library can solve the first issue, it make compile succeed without errors. This example is from MPC5748G ENET , the right result is in Yue Li's user guide (the attachment). Then I try to debug the project, the projected can be debugged. But when I try to send ethernet packet, it will not send me the same one. I wonder if you have the same problem when you debug this example project. 

thanks,

Jupeng

0 Kudos

298 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

unfortunately this example is for MPC574xG Mother board and Daughter card  ( Evaluation System for MPC574xB/C/G Family | NXP  ). With this configuration example works as expected: 

s32ds_2019-08-13_15-13-40.png

Anyway - as a part of S32DS Installation - there are Ethernet examples: 

pastedImage_153.png

Hope it helps. 

Jiri 

0 Kudos

298 Views
961271210
Contributor I

Hi,

I changed the library as same as you. Then the issue is solved. But the debug interface which is used in my project is OpenSDA interface. I wonder if there is some differences between the OpenSDA and the USB Multilink ?

pastedImage_1.png

Thanks

Jupeng

0 Kudos

298 Views
961271210
Contributor I

Hi,

I changed the library from EWL nano to standard EWL, but it still can not detect my device. What is EVB?

pastedImage_1.png

0 Kudos