error after update to Arm v1.3 - Update 2

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

error after update to Arm v1.3 - Update 2

1,318 Views
adrianwenger
Contributor III

HI,

after update i can not debug any more....

pastedImage_1.png

Regards,

Adrian

Labels (1)
0 Kudos
7 Replies

1,032 Views
jiri_kral
NXP Employee
NXP Employee

Hi Adrian, 

I can't reproduce your issue - but I see that you have different PE micro debug plugin version. After last update - I have on my machine installed  com.pemicro.debug.gdbjtag.pne plugin ver. 2.9.6, your vesion is 2.7.0. 

As a quick fix without any investigation - just update PE micro plugin 

https://community.nxp.com/thread/447395?commentID=890477#comment-890477

Jiri

0 Kudos

1,032 Views
adrianwenger
Contributor III

Hi,

if i use the version 2.9..., the same error appears:

pastedImage_1.png

0 Kudos

1,032 Views
stanish
NXP Employee
NXP Employee

Hello Adrian,

you posted that you are targeting S32K144EVB but your GDB console shows NXP_KEx_S9KEAZ128M4 which is completely different part. This is the reason why flash programming fails - you target MCU and flash programming algorithm must match.

I'd recommend you:

1) create a new project and select the device you are targeting (S32K144).

2) open debug configuration dialog  (Menu Run -> Debug Configuration)

3) select the appropriate configuration for your project (typically there are 3 variants for each build configuration - RAM_Debug, Debug, Release), Debug interface (assume you use OpenSDA) and click on "Debug" button

 

pastedImage_1.png   

Are you able to run the debug session?

Stan

0 Kudos

1,032 Views
adrianwenger
Contributor III

???

0 Kudos

1,032 Views
martin_kovar
NXP Employee
NXP Employee

Hello Adrian,

this is very strange issue. From my point of view, it could be caused by some error during update installation. Could you please try to uninstall the Design Studio including all PEMicro drivers and try it install once again?

Regards,

Martin

PS: which operating system you use?

0 Kudos

1,032 Views
martin_kovar
NXP Employee
NXP Employee

Hello,

could you please write me, which microcontroller you use?

Regards,

Martin

0 Kudos

1,032 Views
adrianwenger
Contributor III

Hi,

yes, i use the S32K144EVB

regards

0 Kudos