Project with S32 Design Studio and IAR program flash issue

cancel
Showing results for 
Search instead for 
Did you mean: 

Project with S32 Design Studio and IAR program flash issue

191 Views
Contributor III

Hello,

I am facing issue for flash and debug the program when created with IAR compiler. 

Following below steps

1. New Application project 

chaitanya_kalya_0-1599542291332.png

and when I compile it then It don't have any issue.

But when I try to flash it then it is just building and after some time PE multilink is getting disconnected. 

chaitanya_kalya_1-1599542441094.png

after abort getting below error 

chaitanya_kalya_2-1599542469477.png

Please help me to solve this problem.

thank you in advance.

0 Kudos
6 Replies

174 Views
Contributor III

Hello @jiri_kral 

 

Thank you for quick response. I am using S32K144 EVB and board is powered up properly. When I flash example project then there is no issues. Issue is only when I create new project and try to flash it. 

 

I am attaching sample project that I have created.

0 Kudos

184 Views
NXP Employee
NXP Employee

Hi, 

What is your board - it is custom one or NXP EVB? Is your board properly powered up? Is tour PE Multilink probe correctly connected to board? 

 

Jiri 

0 Kudos

179 Views
Contributor III

I am using S32K144 EVB. Board is powered up properly. When I use example project then there is no issues. Issue is only when I create new project. 

0 Kudos

166 Views
NXP Employee
NXP Employee

Hi, 

I tried import your project and there is no issue with flashing on my side. I used PE Micro Multilink FX. Can  you share output from Debug console - if there is any? You can also try to re-install PE Micro drivers - with default install path located in c:\NXP\S32DS_ARM_v2.2\Drivers\ 

 

Jiri

0 Kudos

144 Views
Contributor III

Hello @jiri_kral ,

 

Thank you for the quick response.

 

For flash might be there is some issue with the EVB board. It is not able to flash with PE Multilink but able to flash with OpenSDA. 

 

 

0 Kudos

137 Views
NXP Employee
NXP Employee

Hi, 

 

what about power supply when connected to PE Micro Multilink? Did you provide external 12V or you are using USB? 

 

Jiri

0 Kudos