[5744P] S32 Design Studio include Green Hills Compiler Problem

cancel
Showing results for 
Search instead for 
Did you mean: 

[5744P] S32 Design Studio include Green Hills Compiler Problem

1,249 Views
erichsu
Contributor I

I use S32 DS IDE(v1.1) include GHS compiler(v2015.1.6) and run test3 project in KIT33908MBEVBE+KITMPC5744DBEVM.

The project can be compiled, but the process occurred error in debug mode.

It brothers me one week.Could someone give me advice, please?

Thanks a lot.

 

168595_168595.pngpastedImage_2.png

Original Attachment has been moved to: test3.zip

Labels (2)
0 Kudos
4 Replies

462 Views
erichsu
Contributor I

Hi Martin,

I delete .elf, but some problem occurred as follows. Where do I need to set it?

Thanks a lot.

pastedImage_1.png

0 Kudos

462 Views
erichsu
Contributor I

Hi Martin,

I add the command as follows, but  there was an error after compilation.

Where should I set  "Build with optimizations off (-Onone) or debug options on (-Odebug) or a variation of those."?

pastedImage_5.png

Console log:

pastedImage_4.png

0 Kudos

462 Views
martin_kovar
NXP Employee
NXP Employee

Hi,

I am sorry I forgot one point. You have to delete .elf from command inserted to Post-build step.

Regards,

Martin

0 Kudos

462 Views
martin_kovar
NXP Employee
NXP Employee

Hi,

This sounds like a known issue with GHS build tools. There is a workaround which does not completely resolve the issue, but it improves debugging:

  • Build with optimizations off (-Onone) or debug options on (-Odebug) or a variation of those.
  • After the build, run our gstrip utility on the executable and remove .debug_framegstrip -r=.debug_frame <executable>

 

 

Add this command as a post-build step:

pastedImage_1.png

Please let me know, if it helps you.

Regards,

Martin

0 Kudos