MC9S12A128B - Debug Crash

cancel
Showing results for 
Search instead for 
Did you mean: 

MC9S12A128B - Debug Crash

1,462 Views
SebaS
Contributor III

Hello again!!

I'm having a problem with HCS12.... It's a very rare one.. Let`s start from basics....
This is waht i'm using:

- MC9S12A128B
- 20MHz oscillator CLK and no PLL, no nothing so the uC is at 10MHz
- PEAR_NECLK=1; // PE 4-7 General I/O
- DDRE=0xF0; // PE 4-7 Output

*** TIMER IC ***
TIOS=0x00; // Channel 4 as IC
TCTL3=0x03; // IC Channel 4 interrups with both edges
TIE=0x10; // Channel 4 IRQ Enable
TSCR2=0x00; // No prescaler
TSCR1=0x80; // Timer Enabled

The code is a basic program that analizes the IC values... is very simple it doesn't matter.... the problem is that I debug it, no WARNINGS, no ERRORS.... Then I run it and it works fine because i've got some LEDs to monitorize the process... now here's the problem... I HALT it and it's like the uC RESETS itself....

At first I set the data in the debugger to be scoped periodically and while the program is running I can see the values of the data wich are correct.... then when I HALT it and BOOOMMM!!! all variables go to ZERO and the SOURCE windows blanks and appears a message saying "no reference source found".... That cause me a HUGE problem because I can debug correctly my soft so I can't make any corrections or test the proper funcionallity... I'm blowing my head trying to solve this but I can't tell why it's not working fine.. It's the first time it happens to me....

I've been using this from a long time.... At first I guess it could be a problem of sync because I allways use a 16MHz OSC CLK but know I need to speed it up so I'm using a 20MHz one because PLL blows my mind!!.... I checked the IO_DELAY and it's correctly set at 11....(240/20)-1=11

PLEASE ANY HELP WOULD BE STRONGLY APPRECIATED.... THANKS IN ADVANCE!!!

 

Alban clarified subject

Message Edited by Alban on 2007-02-28 02:10 PM

Labels (1)
0 Kudos
3 Replies

33 Views
SebaS
Contributor III

I forgot to say..... WD_COP is disable.... and one more thing when all of this happends in the command line there's no ERROR..... before it says ILLEGAL BP but know it stops saying that.....

Another strange thing...Follow the secuence:

1- Debug
2- Run
3- HALT---- here's the crash variables go to "0" and "no reference source found"
4- Run again.... it runs
5- HALT---- HALT normally but InputCapture works very bad
6- Run again.... it runs
7- HALT---- HALT normally but InputCapture works very bad
8- Run again.... it runs
9- HALT---- HALT normally but InputCapture works very bad

I'm AMAZE!!!

BreakPoint works fine.... so I can't UNDERSTAND IT!!!

THANKS AGAIN.........

 

Alban clarified subject

Message Edited by Alban on 2007-02-28 02:11 PM

0 Kudos

33 Views
Alban
Senior Contributor II
Hello SebaS,
 
For those you might wish to help, may you please indicate what you are debugging with ?
As your setup crashes on debug, we need to know your setup.
 
Regards,
Alban.
0 Kudos

33 Views
SebaS
Contributor III
Hello!! Thanks for your answer... I finally fixed it... Don't ask why, I've just create another project, copy and paste de source files from the other project and it's start working just fine.... Unless the other one keep having debug crashes... Honestly I've got no idea about why is that... I always create a project using the wizard and I always do it in the same way....

Thanks anyway
0 Kudos