Device broken

cancel
Showing results for 
Search instead for 
Did you mean: 

Device broken

419 Views
Contributor II

Hello,

My device is broken it starts until the Atmosphere screen then it stops with the blue LED continu on, no further activity.

-None of the resets helps

-New 'out of the box firmware.bin' does not help.

-Other .bin files from the NXP website will upload to the device but end in the same screen.

NXP-locked screen.jpg

M 0060370000127D20

ID 410486749406069B

I know i was a early adapter but this lifetime is very short,

Greetings,

Hans Volbeda (Netherlands)

Labels (1)
Tags (3)
0 Kudos
7 Replies

26 Views
NXP Employee
NXP Employee

Hi,

I do not believe your kit is dead... I rather suspect a SW issue.

I need to ask few questions to figure out what happened and how to fix.

- Do you have a hexiwear docking station?

- Can you confirm you can still enter MSD mode to reflash FW ? (seems to be the case from what you wrote)

- Did you try switching to THREAD mode ?

Flashing the latest out of the box application FW, and connecting your kit to your PC, you should be able to see a log in a terminal window (teraterm). PLease provide me with this log so I can figure out what is wrong - I have attached my Teraterm set-up to save you time

0 Kudos

26 Views
Contributor II

Hi Eric thanks for the Quick response,

-I don't have a Hexiwear

-I can put a .bin file in the device by  USB Mass Storage Device Programming 

-The first time i tried to make a log 1 the device started almost normal so i could try the THREAD mode, it crashed.

-The second time (i had to reset it again) i uploaded a out of the box.bin file it stopped again on the ATMOSPHERE screen with the blue LED continu on, see Log 2

Thanks for the help,

Hans

0 Kudos

26 Views
NXP Employee
NXP Employee

From what I can read it looks your KW41Z µC is corrupted, K64 looks fine.

Here is the reasonning if you are interested - can help understanding the how the kit works better:

- K64 boot loader seems also ok, cause you can still use MSD mode (Most of the time users crash the k64 bootloader leading to a kit not booting at all)

- The K64 cannot complete its booting sequence therefore you are stuck. This said it looks ok from the log 

- We can read in the log that K64 is asking KW41Z Mac address and not getting any answer.

  • Am not sure yet whether just reflashing the core image will be sufficient, but we can try:

You mentionned you tried flashing different apps, but can you confirm you tried flashing the KW41Z hybrid application ?

The process to flash the KW41Z hybrid application is the same as for a K64 image (Reset + SW3 and drag and drop)

Am attaching the latest version to this message. This is the one to use.

Because you have not used the hexiwear docking station, I would be very surprised that the KW41Z bootloader is coorupted.

0 Kudos

26 Views
Contributor II

Eric,

 

THANKS! that was the trick, it works fine now but i don't understand how, how does the device know in what part of memory it must be and in what chip if i upload it just by dropping it by USB programming?

-I didn't try the KW41Z hybrid application because;

I tought that i needed a Hexiwear dockingstation in order to programm the bootloaders  as i read in the manual here; 4.1.5. (Re)Programming of K64F and KW41Z Bootloaders.

In the attached picture i understood that you have to select the chip with the dip switches before programming, that did I understand, just dropping it in by usb i don't understand.

But thanks again, i am happy that it works again…..

Hans Volbeda.

hexiwear.PNG

0 Kudos

26 Views
NXP Employee
NXP Employee

Very glad to read it is fixed.

To answer your question:

Without docking station, K64 parses the binary and detects whether it is a K64 binary or a KW41 binary and passes on to KW41Z when applicable. As the only 'input' is USB directly to K64, K64 needs to mange this

On a docking station it goes though K20 first via USB and then, we can redistribute the signals directly to the right micro controler via the switches:

pastedImage_3.png

This also explains why it is very easy to overwrite bootloaders with a docking station while it is not easy when kit is directly plug to PC via USB 

On my side I am not clear how you succeeded in corrupting  KW41Z wo a docking station... you are the first user to my knowledge who achieved this :smileygrin:

0 Kudos

26 Views
Contributor II

Eric,

I don't understand it also. My device is permanently connected to my PC by USB during the night the battery goes empty so next morning the device starts up with my computer. Until one day, it ended in the Atmosphere screen that is where i called your help. So there was no special reason (programming or so) why it ended up broken.

Maybe it wil be defective again tomorrow or later we will see,

Greetings,

Hans

0 Kudos

26 Views
Contributor II

Today, 30-7-2019 it's still working!

Greetings Hans.

0 Kudos