Cannot Connect Rapid IoT to NXP Modular Gateway via Thread

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Connect Rapid IoT to NXP Modular Gateway via Thread

223 Views
Contributor II

Hello,

I have Rapid IoT programmed with Rapid IoT Kit Out-of-Box Demo which I built through Rapid IoT Studio and then downloaded to Rapid IoT via USB. Also have NXP Modular Gateway with 1.8.7 firmware and the gateway is commissioned using the MG for Rapid IoT iOS app).

After I commission Rapid IoT as a End Node on the Gateway (using MG for Rapid IoT iOS app), no matter what I do, I can't get Rapid IoT to join the gateway's Thread network. When I press the Join switch on Rapid IoT to initiate join, the white LED never comes on and Rapid IoT never joins the Thread network.

How do I make this work?

Has anyone else been able to get it to work?

Thanks

6 Replies

8 Views
NXP TechSupport
NXP TechSupport

Hello,

All the questions regarding the NXP Modular Gateway should be post in it's own community which is the   NXP Modular IoT Framework .

Are you sure that your device is receiving joiners? Do you have a way to see the packets in the air so we can know what might be happening ? Are you sure that the rapid iot it's requesting to join the network ?

Also, could you please help me confirm you followed all the steps mentioned in the Rapid IoT Prototyping Tool User’s Guide, chapter 3.20. NXP Modular IoT Gateway? 

Regards,
Estephania

0 Kudos

8 Views
Contributor II

I'm running the standard gateway firmware (1.8.7) and the standard Rapid

IoT demo app rebuilt through Rapid IoT Studio. Can I get a copy of the

original Rapid IoT binary that comes installed on the Rapid IoT from the

factory? I'm wondering whether the demo version found on Rapid IoT Studio

is known to work with the Thread connections to NXP Modular Gateway. Is

Channel 15 the right channel?

On Wed, Aug 28, 2019 at 11:21 AM estephania_martinez <

0 Kudos

8 Views
NXP TechSupport
NXP TechSupport

Hello,

The OOB example form the studio should be fine, nonetheless, I believe it is the channel 25, could you please try with that channel ?

Regards,

Estephania

0 Kudos

8 Views
Contributor II

The Rapid IoT OOB firmware appears to be using channel 15 which is what it

reports on the serial terminal. I don't know how to check what the gateway

is using...it's the OOB gateway firmware running there.

Here's the Rapid IoT terminal message when it tries to join:

Setting channel to 15

Joining network

THR Attaching...

Join failed

On Wed, Aug 28, 2019 at 1:48 PM estephania_martinez <admin@community.nxp.com>

0 Kudos

8 Views
NXP Employee
NXP Employee

Can you attached the full log of both Rapid-IoT and modular gateway for further investigations ?

For recovering default Rapid-IoT application please follow paragraph 4. of Rapid-IoT User Guide mentionning the procedure: https://www.mouser.com/pdfdocs/NXP_SLN-RPK-NODE-UG.pdf 

If at some point , your Rapid-IoT is cateched in a unknown state, please follow this video guide to recover default application & bootloaders binaries.

Recovering k64f &amp; kw41z applications binaries 

Recovering k64f &amp; kw41z bootloaders binaries 

8 Views
NXP TechSupport
NXP TechSupport

Hello,

I'll need to investigate further on this, as soon as I get an update I'll let you know.

Regards ,
Estephania

0 Kudos