ethtool support for P2040

cancel
Showing results for 
Search instead for 
Did you mean: 

ethtool support for P2040

549 Views
gouravjain
Contributor IV

Hello all,

in my custom board, which is based on P2040RDB, by default "ethtool" utility is not available. So, I downloaded from "ethtool-4.18 - utility for controlling network drivers and hardware ". 

Could any one pls tell me how to cross compile for P2040 chipset??

Thanks,

Gourav 

0 Kudos
3 Replies

288 Views
Pavel
NXP TechSupport
NXP TechSupport

NXP offers SDK 2.0 Linux BSP for the P2041RDB board. This SDK provides standalone toolchain.

See the Section 3.3.7 of SDK v2.0-1703 documentation for standalone toolchain using:

https://www.nxp.com/docs/en/supporting-information/QORIQ-SDK-2.0-IC-REV0.pdf


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

288 Views
gouravjain
Contributor IV

Hello Pavel Chubakov,

Thanks for addressing my question.

Actually i have downlaoded and cross compiled seperatly. 

while running ethtool at target i observed very wiered thing. 

1) after assigning ip to interface, (while ethernet cable is connected)

  root@hmd-modem::~# ./ethtool fm1-gb3
Settings for fm1-gb3:
Supported ports: [ MII ]
Supported link modes: 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: No
Advertised link modes: 1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 7
Transceiver: external
Auto-negotiation: off
Current message level: 0xffffffff (-1)
drv probe link timer ifdown ifup rx_err tx_err tx_q ueued intr tx_done rx_status pktdata hw wol 0xffff8000
Link detected: yes

2) even all the messages are same while removing cable.

  root@hmd-modem::~# ./ethtool fm1-gb3
Settings for fm1-gb3:
Supported ports: [ MII ]
Supported link modes: 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: No
Advertised link modes: 1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 7
Transceiver: external
Auto-negotiation: off
Current message level: 0xffffffff (-1)
drv probe link timer ifdown ifup rx_err tx_err tx_q ueued intr tx_done rx_status pktdata hw wol 0xffff8000
Link detected: yes

Link detected must be : no when cable is removed.

Could you pls let me know what could be the issue??

thanks,

Gourav

 

0 Kudos

288 Views
gouravjain
Contributor IV

Hi Pavel Chubakov ,

waiting for you reply ....

0 Kudos