P2041: SRIO link test in UBOOT

cancel
Showing results for 
Search instead for 
Did you mean: 

P2041: SRIO link test in UBOOT

461 Views
gouravjain
Contributor IV

Hi All,

In our board based on P2041rdb, SRIO lines are connected to IDT SRIO switch.

Its in 2x mode. serdes lines SD_TX04/SD_RX04, SD_TX05/SD_RX05 are connected to IDT SRIO switch.

I want to perform link test in UBOOT and then linux. 

Can some one let me know how to proceed further ??

Thanks,

Gourav

0 Kudos
13 Replies

196 Views
Pavel
NXP TechSupport
NXP TechSupport

Use Ubuntu 12 or Ubuntu 14. Do not use Ubuntu 16 or Ubuntu 18.

Usually the following command sequence is used for SDK 2.0 installing under Ubuntu 14.04 64-bit:

  1. sudo apt-get install ubuntu-minimal ubuntu-standard patch vim-common sed wget subversion git-core coreutils libbonobo2-common unzip texi2html texinfo libsdl1.2-dev docbook-utils gawk python-pysqlite2 diffstat make gcc build-essential xz-utils g++ desktop-file-utils chrpath libgl1-mesa-dev libglu1-mesa-dev autoconf automake groff libtool xterm libncurses5-dev cvs tofrodos

 

  1. a) command: ls -l /bin/sh

                Message:  /bin/sh -> dash

  1. b) command: sudo dpkg-reconfigure dash

                Answer after password – No

                Message:

                Removing 'diversion of /bin/sh to /bin/sh.distrib by dash'

                Adding 'diversion of /bin/sh to /bin/sh.distrib by bash'

                Removing 'diversion of /usr/share/man/man1/sh.1.gz to /usr/share/man/man1/sh.distrib.1.gz by dash'

                Adding 'diversion of /usr/share/man/man1/sh.1.gz to /usr/share/man/man1/sh.distrib.1.gz by bash'

  1. c) command for checking: ls -l /bin/sh

                Message: /bin/sh -> bash

 

  1. mount SDK source .iso file
  2. cd <sdk-install-dir>.
  3. ./sources/meta-freescale/scripts/host-prepare.sh

Usually Linux recommends also run the following command: sudo usr/sbin/visudo

  1. Download and unpack the QorIQ Linux SDK v2.0-1703.bz2

Install SDK v2.0-1703

  1. bitbake fsl-image-minimal


Have a great day,
Pavel Chubakov

-------------------------------------------------------------------------------
Note:

This thread is continued as a private discussion with the submitter,
NXP support is not following the thread anymore.
-------------------------------------------------------------------------------

0 Kudos

196 Views
Pavel
NXP TechSupport
NXP TechSupport

New version of SDK usually uses new version of Linux kernel. For example SDK 2.0 Linux kernel is Linux kernel 4.1.8.

Some problems or mistakes are fixed in new SDK version.


Have a great day,
Pavel Chubakov

-------------------------------------------------------------------------------
Note:

This thread is continued as a private discussion with the submitter,
NXP support is not following the thread anymore.
-------------------------------------------------------------------------------

0 Kudos

196 Views
gouravjain
Contributor IV

I'm trying to compile SDK-2 kernel,  but its giving error...

While SDK-1.4 is working fine. So if you guide me how to use SRIO in SDK-1.4, will be easier for me to proceed.

0 Kudos

196 Views
Pavel
NXP TechSupport
NXP TechSupport

There is the same driver is the SDK 2.0 ("./drivers/uio/fsl_srio_uio.c").


Have a great day,

Pavel Chubakov

-------------------------------------------------------------------------------
Note:

This thread is continued as a private discussion with the submitter,
NXP support is not following the thread anymore.
-------------------------------------------------------------------------------

0 Kudos

196 Views
gouravjain
Contributor IV

yeah ..i understood your's point.

But, my question is why should I use SDK-2 ?? While same srio files are available in SDK-1.4

0 Kudos

196 Views
Pavel
NXP TechSupport
NXP TechSupport

Find SRIO driver in kernel source folder.

The following path is needed if T1040RDB board:

/QorIQ-SDK-V2.0-20160527-yocto/build_t1040d4rdb/tmp/work/t1040d4rdb-fsl-linux/linux-qoriq/4.1-r0/git/drivers/uio

 

Use similar path for the P2041.


Have a great day,
Pavel Chubakov

196 Views
gouravjain
Contributor IV

Hi Pavel,

I can see "./drivers/uio/fsl_srio_uio.c" in my working SDK-1.4. 
So whats the point of going for higher version SDK-2???

Cant i use all the SRIO related features by using SDK-1.4?

0 Kudos

196 Views
gouravjain
Contributor IV

Thanks for help.

I missed out to enable one more thing. Anyways i got the source code.

Now i'm going to fuse new image into the card and i'll let you know if any issue comes.

0 Kudos

196 Views
Pavel
NXP TechSupport
NXP TechSupport

Use the following page:

https://www.nxp.com/support/developer-resources/run-time-software/linux-software-and-development-too...

 

Find "Download" on this page.

Have a great day,
Pavel Chubakov

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

196 Views
gouravjain
Contributor IV

Hi Pavel,

I have downloaded SDK2 and able to cross compile kernel in standalone basis. 
Can you pls let me know where i can find srio files in kernel dir, since im not able to see any relevant files

thanks,

Gourav

0 Kudos

196 Views
Pavel
NXP TechSupport
NXP TechSupport

See the Sections 9.9.18 and 12.3.5 of SDK 2.0-1703 documentation:

https://www.nxp.com/docs/en/supporting-information/QORIQ-SDK-2.0-IC-REV0.pdf

 

These Sections contains information for installing and testing SRIO on the P2041/P3041/P4080/P5020/T4240/B4860.

Have a great day,
Pavel Chubakov

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

196 Views
gouravjain
Contributor IV

Hi Pavel,

Thanks for the response. 

Can you pls share the link from where i can download SDk-2.0 freely.

0 Kudos

196 Views
gouravjain
Contributor IV

Currently we are using "Linux-3.8.13-rt9-QorIQ-SDK-V1.4" and there is no USDPAA SRA application.
Pls let me know how to get it.

0 Kudos